Skip to content

Updated active_record adapter to use modern query methods #83

Merged
merged 1 commit into from Jan 23, 2013

2 participants

@myrlund
myrlund commented Jan 20, 2013

Eliminating hordes of deprecation warnings in Rails 4, but breaks compatibility with Rails 2.

@rsl
Owner
rsl commented Jan 23, 2013

yeh. i was thinking about no longer supporting rails 2 on the upcoming [eventually] stringex 2.0. i need to finish this stupid data mapper adapter first though. i think this is a good time to do it.

@rsl
Owner
rsl commented Jan 23, 2013

i'd change the validation code too. also, travis seems to be stuck on this. i've had issues with travis builds on stringex myself before. :/

@rsl rsl merged commit 6ba1528 into rsl:master Jan 23, 2013

1 check was pending

Details default The Travis build is in progress
@rsl
Owner
rsl commented Jan 23, 2013

looks like i changed the on create i had somewhere already. can't find it. merging this. thanks.

@myrlund myrlund deleted the myrlund:deprecation branch Jan 23, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.