Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 50 lines (41 sloc) 1.134 kb
2e1b239 @dchelimsky use the correct ruby-debug for the ruby version
dchelimsky authored
1 source "http://rubygems.org"
62f1bde @dchelimsky update dependencies across development repos
dchelimsky authored
2
6df9d2f @dchelimsky align Gemfiles across rspec dev repos
dchelimsky authored
3 ### rspec libs
9490893 @dchelimsky reinstate cucumber and aruba
dchelimsky authored
4 %w[rspec rspec-core rspec-expectations rspec-mocks].each do |lib|
957b368 @dchelimsky Rollback to earlier approach to including other libs.
dchelimsky authored
5 library_path = File.expand_path("../../#{lib}", __FILE__)
6 if File.exist?(library_path)
7 gem lib, :path => library_path
8 else
ddaf0af @myronmarston Use git protocol rather than https for bundled rspec gems.
myronmarston authored
9 gem lib, :git => "git://github.com/rspec/#{lib}.git"
957b368 @dchelimsky Rollback to earlier approach to including other libs.
dchelimsky authored
10 end
62f1bde @dchelimsky update dependencies across development repos
dchelimsky authored
11 end
2e1b239 @dchelimsky use the correct ruby-debug for the ruby version
dchelimsky authored
12
6df9d2f @dchelimsky align Gemfiles across rspec dev repos
dchelimsky authored
13 ### dev dependencies
11b070c @dchelimsky ci: back to 0.9
dchelimsky authored
14 gem "rake", "~> 0.9"
9490893 @dchelimsky reinstate cucumber and aruba
dchelimsky authored
15 gem "cucumber", "~> 0.10.2"
16 gem "aruba", "~> 0.3.6"
f76caf3 @myronmarston Add scripts that run specs/cukes against all supported rubies.
myronmarston authored
17 gem "rcov", "0.9.9", :platforms => :mri
6df9d2f @dchelimsky align Gemfiles across rspec dev repos
dchelimsky authored
18 gem "relish", "0.2.0"
19 gem "guard-rspec", "0.1.9"
20 gem "growl", "1.0.3"
c228993 @dchelimsky lock ZenTest at ~> 4.4.2
dchelimsky authored
21 gem "ZenTest", "~> 4.4.2"
6df9d2f @dchelimsky align Gemfiles across rspec dev repos
dchelimsky authored
22 gem "nokogiri", "1.4.4"
c6cac07 @ldenman Add autotest-fsevent to bundle when ruby platform is darwin.
ldenman authored
23
4656bd9 @dchelimsky update Gemfile to address build issues with 1.9.1
dchelimsky authored
24 platforms :mri_18 do
25 gem 'ruby-debug'
c6cac07 @ldenman Add autotest-fsevent to bundle when ruby platform is darwin.
ldenman authored
26 end
27
4656bd9 @dchelimsky update Gemfile to address build issues with 1.9.1
dchelimsky authored
28 platforms :mri_19 do
29 gem 'linecache19', '0.5.11' # 0.5.12 cannot install on 1.9.1, and 0.5.11 appears to work with both 1.9.1 & 1.9.2
30 gem 'ruby-debug19'
31 gem 'ruby-debug-base19', RUBY_VERSION == '1.9.1' ? '0.11.23' : '~> 0.11.24'
f76caf3 @myronmarston Add scripts that run specs/cukes against all supported rubies.
myronmarston authored
32 end
33
34 platforms :mri_18, :mri_19 do
6df9d2f @dchelimsky align Gemfiles across rspec dev repos
dchelimsky authored
35 gem "rb-fsevent", "~> 0.3.9"
36 gem "ruby-prof", "~> 0.9.2"
2e1b239 @dchelimsky use the correct ruby-debug for the ruby version
dchelimsky authored
37 end
fcf781a @spicycode Adding jruby-openssl to the jruby platform bundle to eliminate warnings
spicycode authored
38
39 platforms :jruby do
40 gem "jruby-openssl"
41 end
6df9d2f @dchelimsky align Gemfiles across rspec dev repos
dchelimsky authored
42
43 ### rspec-core only
44 gem "mocha", "~> 0.9.10"
45 gem "rr", "~> 1.0.2"
d37bc38 @myronmarston Downgrade flexmock to last version that is compatible with 1.8.6 so our ...
myronmarston authored
46 gem "flexmock", "0.8.8"
6df9d2f @dchelimsky align Gemfiles across rspec dev repos
dchelimsky authored
47
48 ### optional runtime deps
49 gem "syntax", "1.0.0"
Something went wrong with that request. Please try again.