Skip to content
This repository
Newer
Older
100644 60 lines (49 sloc) 1.175 kb
2e1b2399 »
2010-06-25 use the correct ruby-debug for the ruby version
1 source "http://rubygems.org"
62f1bde3 »
2010-10-22 update dependencies across development repos
2
6df9d2f1 »
2010-12-12 align Gemfiles across rspec dev repos
3 ### rspec libs
94908931 »
2011-04-18 reinstate cucumber and aruba
4 %w[rspec rspec-core rspec-expectations rspec-mocks].each do |lib|
957b3685 »
2011-02-05 Rollback to earlier approach to including other libs.
5 library_path = File.expand_path("../../#{lib}", __FILE__)
6 if File.exist?(library_path)
7 gem lib, :path => library_path
8 else
ddaf0af2 »
2011-03-28 Use git protocol rather than https for bundled rspec gems.
9 gem lib, :git => "git://github.com/rspec/#{lib}.git"
957b3685 »
2011-02-05 Rollback to earlier approach to including other libs.
10 end
62f1bde3 »
2010-10-22 update dependencies across development repos
11 end
2e1b2399 »
2010-06-25 use the correct ruby-debug for the ruby version
12
6df9d2f1 »
2010-12-12 align Gemfiles across rspec dev repos
13 ### dev dependencies
436e818e »
2011-06-11 dev: add rdoc to Gemfile
14 gem "rake", "0.9.2"
f995279d »
2011-07-12 dev: upgrade cucumber
15 gem "cucumber", "1.0.1"
a43cf093 »
2011-06-20 dev: update cucumber, aruba, and move some gems around Gemfile
16 gem "aruba", "0.4.2"
dc102cbb »
2011-10-28 bump ZenTest to silence 1.9.3 deprecation warning
17 gem "ZenTest", "4.6.2"
7ab7f08c »
2011-08-21 update a couple of dev dependencies
18 gem "nokogiri", "1.5.0"
724b8ef2 »
2011-10-23 need fakefs for ci
19 gem "fakefs", "0.4.0", :require => false
c6cac07f »
2010-12-04 Add autotest-fsevent to bundle when ruby platform is darwin.
20
fcf781a2 »
2010-11-28 Adding jruby-openssl to the jruby platform bundle to eliminate warnings
21 platforms :jruby do
22 gem "jruby-openssl"
23 end
6df9d2f1 »
2010-12-12 align Gemfiles across rspec dev repos
24
25 ### rspec-core only
26 gem "mocha", "~> 0.9.10"
27 gem "rr", "~> 1.0.2"
d37bc380 »
2011-02-26 Downgrade flexmock to last version that is compatible with 1.8.6 so o…
28 gem "flexmock", "0.8.8"
6df9d2f1 »
2010-12-12 align Gemfiles across rspec dev repos
29
30 ### optional runtime deps
31 gem "syntax", "1.0.0"
66e835d7 »
2011-06-20 ci: exclude local dev gems from travis bundle
32
33 group :development do
708a4f1f »
2011-10-09 bump relish version to ~> 0.5.0
34 gem "relish", "~> 0.5.0"
92f273b8 »
2011-10-14 upgrade guard-rspec and rb-fsevent
35 gem "guard-rspec", "0.5.0"
66e835d7 »
2011-06-20 ci: exclude local dev gems from travis bundle
36 gem "growl", "1.0.3"
8f44f461 »
2011-07-23 dev: add spork
37 gem "spork", "0.9.0.rc9"
66e835d7 »
2011-06-20 ci: exclude local dev gems from travis bundle
38
7cf6233e »
2011-08-24 dev: include rcov w/ jruby env
39 platforms :mri_18, :jruby do
7ab7f08c »
2011-08-21 update a couple of dev dependencies
40 gem "rcov", "0.9.10"
7cf6233e »
2011-08-24 dev: include rcov w/ jruby env
41 end
42
43 platforms :mri_18 do
66e835d7 »
2011-06-20 ci: exclude local dev gems from travis bundle
44 gem 'ruby-debug'
45 end
46
47 platforms :mri_19 do
39a074a6 »
2011-10-01 dev: update Gemfile for ruby-1.9.3
48 if RUBY_VERSION == '1.9.2'
49 gem 'linecache19'
50 gem 'ruby-debug19'
51 gem 'ruby-debug-base19'
52 end
66e835d7 »
2011-06-20 ci: exclude local dev gems from travis bundle
53 end
54
55 platforms :mri_18, :mri_19 do
92f273b8 »
2011-10-14 upgrade guard-rspec and rb-fsevent
56 gem "rb-fsevent", "~> 0.4.3.1"
69ff6702 »
2011-07-17 update ruby-prof
57 gem "ruby-prof", "~> 0.10.0"
66e835d7 »
2011-06-20 ci: exclude local dev gems from travis bundle
58 end
59 end
Something went wrong with that request. Please try again.