Permalink
Browse files

remove unnecessaries from Rakefile

  • Loading branch information...
dchelimsky committed Jan 26, 2010
1 parent 2d6feed commit 022f9076a8599f5825e3af6e64f96cf249b7f7f8
Showing with 6 additions and 16 deletions.
  1. +3 −14 Rakefile
  2. +3 −2 rspec-core.gemspec
View
@@ -24,24 +24,20 @@ begin
gem.add_development_dependency "rspec-expectations", ">= #{Rspec::Core::Version::STRING}"
gem.add_development_dependency "rspec-mocks", ">= #{Rspec::Core::Version::STRING}"
gem.add_development_dependency('cucumber', '>= 0.5.3')
- # gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
end
Jeweler::GemcutterTasks.new
rescue LoadError
puts "Jeweler (or a dependency) not available. Install it with: gem install jeweler"
end
begin
- Rspec::Core::RakeTask.new :spec do |t|
- t.pattern = "spec/**/*_spec.rb"
- end
+ Rspec::Core::RakeTask.new :spec
desc "Run all examples using rcov"
Rspec::Core::RakeTask.new :rcov => :cleanup_rcov_files do |t|
t.rcov = true
t.rcov_opts = %[-Ilib -Ispec --exclude "mocks,expectations,gems/*,spec/resources,spec/lib,spec/spec_helper.rb,db/*,/Library/Ruby/*,config/*"]
t.rcov_opts << %[--no-html --aggregate coverage.data]
- t.pattern = "spec/**/*_spec.rb"
end
rescue LoadError
puts "Rspec core or one of its dependencies is not installed. Install it with: gem install rspec-meta"
@@ -57,7 +53,7 @@ task :clobber do
rm_rf 'coverage'
end
-if RUBY_VERSION == '1.9.1'
+if RUBY_VERSION.to_f >= 1.9
Cucumber::Rake::Task.new :features do |t|
t.cucumber_opts = %w{--format progress}
end
@@ -76,15 +72,8 @@ end
Rake::RDocTask.new do |rdoc|
- if File.exist?('VERSION.yml')
- config = YAML.load(File.read('VERSION.yml'))
- version = "#{config[:major]}.#{config[:minor]}.#{config[:patch]}"
- else
- version = ""
- end
-
rdoc.rdoc_dir = 'rdoc'
- rdoc.title = "rspec-core #{version}"
+ rdoc.title = "rspec-core #{Rspec::Core::Version::STRING}"
rdoc.rdoc_files.include('README*')
rdoc.rdoc_files.include('lib/**/*.rb')
end
View
@@ -9,8 +9,9 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
s.authors = ["David Chelimsky", "Chad Humphries"]
- s.date = %q{2010-01-24}
+ s.date = %q{2010-01-25}
s.default_executable = %q{rspec}
+ s.description = %q{Rspec runner and example group classes}
s.email = %q{dchelimsky@gmail.com;chad.humphries@gmail.com}
s.executables = ["rspec"]
s.extra_rdoc_files = [
@@ -173,7 +174,7 @@ Gem::Specification.new do |s|
s.require_paths = ["lib"]
s.rubyforge_project = %q{rspec}
s.rubygems_version = %q{1.3.5}
- s.summary = %q{Rspec runner and example group classes}
+ s.summary = %q{rspec-core 2.0.0.a2}
s.test_files = [
"spec/resources/example_classes.rb",
"spec/rspec/core/command_line_options_spec.rb",

0 comments on commit 022f907

Please sign in to comment.