Command line is missing --require directive #27

Closed
rickmark opened this Issue May 15, 2010 · 6 comments

2 participants

@rickmark

Hey, wondering if this was removed on purpose or if it was an oversight in the conversion to Rspec 2. Seems that some IDEs use the --require directive to load custom formatters to display progress in their own UI.

I can submit a patch if it should be implemented.

@dchelimsky
RSpec member

Oversight. Patch would be great. Thanks.

@rickmark

I have a working patch on my fork you can integrate, simplest possible solution though I'm not entirely sure how to wrap "require" with testing :-/

@dchelimsky
RSpec member

There is a configuration spec that does something similar for the mocking frameworks: http://github.com/rspec/rspec-core/blob/master/spec/rspec/core/configuration_spec.rb#L18. Just add an example to that spec, and remove all the Intellij configuration files please :)

@rickmark

In that case, do you mind if I add a directive for .idea in to .gitignore?

@dchelimsky
RSpec member

You can add it to ./git/info/excludes - works just like .gitignore but it doesn't get committed to the repo.

@dchelimsky
RSpec member

Add --require command line option

Closed by 8df9054.

@timcharper timcharper pushed a commit to timcharper/rspec-core that referenced this issue Aug 19, 2011
@dchelimsky dchelimsky Add --require command line option
Closes #27.
8df9054
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment