Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 84 lines (70 sloc) 2.374 kb
32cc890 @dchelimsky Development env now works correctly with bundler.
dchelimsky authored
1 require 'bundler'
2 Bundler.setup
3
a8f577a @dchelimsky load paths 'n stuff
dchelimsky authored
4 $LOAD_PATH << File.expand_path("../lib", __FILE__)
dcfcac8 @spicycode Initial commit to rspec-expectations.
spicycode authored
5 require 'rake'
f0e8dd3 @spicycode Adding in a version constant, and regenerating gemspec
spicycode authored
6 require 'rspec/expectations/version'
dcfcac8 @spicycode Initial commit to rspec-expectations.
spicycode authored
7
8 begin
9 require 'jeweler'
10 Jeweler::Tasks.new do |gem|
11 gem.name = "rspec-expectations"
ba95bb1 @dchelimsky change top-level module from Rspec to RSpec
dchelimsky authored
12 gem.version = RSpec::Expectations::Version::STRING
13 gem.summary = "rspec-expectations-#{RSpec::Expectations::Version::STRING}"
cec97d9 @dchelimsky move version to VERSION file
dchelimsky authored
14 gem.description = "rspec expectations (should[_not] and matchers)"
baeb478 @dchelimsky upgrade to jeweler-1.4.0
dchelimsky authored
15 gem.rubyforge_project = "rspec"
d5a1da7 @spicycode Initial jeweler repository creation
spicycode authored
16 gem.email = "dchelimsky@gmail.com;chad.humphries@gmail.com"
17 gem.homepage = "http://github.com/rspec/expectations"
18 gem.authors = ["David Chelimsky", "Chad Humphries"]
6a6d4c8 @dchelimsky just diff
dchelimsky authored
19 gem.add_dependency('diff-lcs', ">= 1.1.2")
3e2e9bd @dchelimsky add features (moved from rspec-core)
dchelimsky authored
20 gem.add_development_dependency('cucumber', ">= 0.6.2")
21 gem.add_development_dependency('aruba', ">= 0.1.1")
ba95bb1 @dchelimsky change top-level module from Rspec to RSpec
dchelimsky authored
22 gem.add_development_dependency('rspec-core', ">= #{RSpec::Expectations::Version::STRING}")
23 gem.add_development_dependency('rspec-mocks', ">= #{RSpec::Expectations::Version::STRING}")
bd16a69 @dchelimsky add post install message
dchelimsky authored
24 gem.post_install_message = <<-EOM
25 #{"*"*50}
26
27 Thank you for installing #{gem.summary}
28
29 #{"*"*50}
30 EOM
dcfcac8 @spicycode Initial commit to rspec-expectations.
spicycode authored
31 end
32 rescue LoadError
f0e8dd3 @spicycode Adding in a version constant, and regenerating gemspec
spicycode authored
33 puts "Jeweler (or a dependency) not available. Install it with: gem install jeweler"
dcfcac8 @spicycode Initial commit to rspec-expectations.
spicycode authored
34 end
35
eb78a17 @dchelimsky add gem:push task (was removed from jeweler)
dchelimsky authored
36 namespace :gem do
37 desc "push to gemcutter"
38 task :push => :build do
ba95bb1 @dchelimsky change top-level module from Rspec to RSpec
dchelimsky authored
39 system "gem push pkg/rspec-expectations-#{RSpec::Expectations::Version::STRING}.gem"
eb78a17 @dchelimsky add gem:push task (was removed from jeweler)
dchelimsky authored
40 end
41 end
42
f75af48 @spicycode Making the default rakefile give friendlier errors when bumping gem vers...
spicycode authored
43 begin
44 require 'rspec/core/rake_task'
ba95bb1 @dchelimsky change top-level module from Rspec to RSpec
dchelimsky authored
45 RSpec::Core::RakeTask.new(:spec)
f75af48 @spicycode Making the default rakefile give friendlier errors when bumping gem vers...
spicycode authored
46 rescue LoadError
ba95bb1 @dchelimsky change top-level module from Rspec to RSpec
dchelimsky authored
47 puts "RSpec core or one of its dependencies is not installed. Install it with: gem install rspec-core"
dcfcac8 @spicycode Initial commit to rspec-expectations.
spicycode authored
48 end
49
a8f577a @dchelimsky load paths 'n stuff
dchelimsky authored
50 begin
51 require 'cucumber/rake/task'
52 Cucumber::Rake::Task.new do |t|
53 t.cucumber_opts = %w{--format progress}
54 end
55 rescue LoadError
56 puts "Cucumber or one of its dependencies is not installed. Install it with: gem install cucumber"
3e2e9bd @dchelimsky add features (moved from rspec-core)
dchelimsky authored
57 end
58
59 task :default => [:check_dependencies, :spec, :cucumber]
dcfcac8 @spicycode Initial commit to rspec-expectations.
spicycode authored
60
61 require 'rake/rdoctask'
62 Rake::RDocTask.new do |rdoc|
63 if File.exist?('VERSION.yml')
64 config = YAML.load(File.read('VERSION.yml'))
65 version = "#{config[:major]}.#{config[:minor]}.#{config[:patch]}"
66 else
67 version = ""
68 end
69
70 rdoc.rdoc_dir = 'rdoc'
71 rdoc.title = "rspec-expectations #{version}"
72 rdoc.rdoc_files.include('README*')
73 rdoc.rdoc_files.include('lib/**/*.rb')
74 end
75
d40404d @dchelimsky add clobber task
dchelimsky authored
76 task :clobber do
108291c @dchelimsky don't diff single line strings
dchelimsky authored
77 rm_rf 'doc'
d40404d @dchelimsky add clobber task
dchelimsky authored
78 rm_rf 'pkg'
79 rm_rf 'tmp'
80 rm_rf 'coverage'
81 end
82
83
Something went wrong with that request. Please try again.