Skip to content
Newer
Older
100644 41 lines (34 sloc) 1001 Bytes
5d631db @dchelimsky update to aruba 0.2.0
dchelimsky authored
1 source "http://rubygems.org"
2
6790c7c @dchelimsky align Gemfiles across rspec dev repos
dchelimsky authored
3 ### rspec libs
7032c39 @dchelimsky update dependencies across development repos
dchelimsky authored
4 %w[rspec-core rspec-expectations rspec-mocks].each do |lib|
6790c7c @dchelimsky align Gemfiles across rspec dev repos
dchelimsky authored
5 library_path = File.expand_path("../../#{lib}", __FILE__)
6 if File.exist?(library_path)
7 gem lib, :path => library_path
8 else
ebaf90a @myronmarston Pull gems from github when they are not available locally on the file…
myronmarston authored
9 gem lib, :git => "git://github.com/rspec/#{lib}.git"
6790c7c @dchelimsky align Gemfiles across rspec dev repos
dchelimsky authored
10 end
7032c39 @dchelimsky update dependencies across development repos
dchelimsky authored
11 end
12
6790c7c @dchelimsky align Gemfiles across rspec dev repos
dchelimsky authored
13 ### dev dependencies
14 gem "rake", "0.8.7"
b932407 @dchelimsky comment aruba/cukes in Gemfile
dchelimsky authored
15 # gem "cucumber", "~> 0.10.2"
16 # gem "aruba", :git => "git://github.com/aslakhellesoy/aruba"
b66c8c3 @dchelimsky update Gemfile to address build issues with 1.9.1
dchelimsky authored
17 gem "rcov", "0.9.9", :platforms => :mri
6790c7c @dchelimsky align Gemfiles across rspec dev repos
dchelimsky authored
18 gem "relish", "0.2.0"
19 gem "guard-rspec", "0.1.9"
20 gem "growl", "1.0.3"
b66c8c3 @dchelimsky update Gemfile to address build issues with 1.9.1
dchelimsky authored
21 gem "nokogiri", "1.4.4"
04eeba1 @dchelimsky add ruby-debug to Gemfile
dchelimsky authored
22
b66c8c3 @dchelimsky update Gemfile to address build issues with 1.9.1
dchelimsky authored
23 platforms :mri_18 do
24 gem 'ruby-debug'
6790c7c @dchelimsky align Gemfiles across rspec dev repos
dchelimsky authored
25 end
26
b66c8c3 @dchelimsky update Gemfile to address build issues with 1.9.1
dchelimsky authored
27 platforms :mri_19 do
28 gem 'linecache19', '0.5.11' # 0.5.12 cannot install on 1.9.1, and 0.5.11 appears to work with both 1.9.1 & 1.9.2
29 gem 'ruby-debug19'
30 gem 'ruby-debug-base19', RUBY_VERSION == '1.9.1' ? '0.11.23' : '~> 0.11.24'
31 end
6790c7c @dchelimsky align Gemfiles across rspec dev repos
dchelimsky authored
32
b66c8c3 @dchelimsky update Gemfile to address build issues with 1.9.1
dchelimsky authored
33 platforms :mri_18, :mri_19 do
6790c7c @dchelimsky align Gemfiles across rspec dev repos
dchelimsky authored
34 gem "rb-fsevent", "~> 0.3.9"
35 gem "ruby-prof", "~> 0.9.2"
36 end
37
38 platforms :jruby do
39 gem "jruby-openssl"
04eeba1 @dchelimsky add ruby-debug to Gemfile
dchelimsky authored
40 end
Something went wrong with that request. Please try again.