Skip to content
Browse files

Development env now works correctly with bundler.

  • Loading branch information...
1 parent f942bac commit 32cc890661f981e5647664d597a8ae2ad0fe4dec @dchelimsky dchelimsky committed Jun 21, 2010
Showing with 34 additions and 5 deletions.
  1. +1 −0 .gitignore
  2. +9 −0 Gemfile
  3. +3 −0 Rakefile
  4. +17 −2 features/support/env.rb
  5. +4 −3 rspec-expectations.gemspec
View
1 .gitignore
@@ -6,3 +6,4 @@ pkg
doc
tmp
rerun.txt
+Gemfile.lock
View
9 Gemfile
@@ -0,0 +1,9 @@
+gem "rake"
+gem "jeweler"
+gem "cucumber"
+gem "aruba"
+gem "autotest"
+gem "diff-lcs"
+gem "rspec-expectations", :path => "."
+gem "rspec-core", :path => "../rspec-core"
+gem "rspec-mocks", :path => "../rspec-mocks"
View
3 Rakefile
@@ -1,3 +1,6 @@
+require 'bundler'
+Bundler.setup
+
$LOAD_PATH << File.expand_path("../lib", __FILE__)
require 'rake'
require 'rspec/expectations/version'
View
19 features/support/env.rb
@@ -1,5 +1,20 @@
-$LOAD_PATH.unshift File.expand_path('../../../lib', __FILE__)
-require 'rspec/expectations'
+require 'bundler'
+Bundler.setup
+
require 'aruba'
+require 'rspec/expectations'
+
+module ArubaOverrides
+ def detect_ruby_script(cmd)
+ if cmd =~ /^rspec /
+ "bundle exec ../../../rspec-core/bin/#{cmd}"
+ elsif cmd =~ /^ruby /
+ "bundle exec #{cmd}"
+ else
+ super(cmd)
+ end
+ end
+end
+World(ArubaOverrides)
View
7 rspec-expectations.gemspec
@@ -9,7 +9,7 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
s.authors = ["David Chelimsky", "Chad Humphries"]
- s.date = %q{2010-06-18}
+ s.date = %q{2010-06-21}
s.description = %q{rspec expectations (should[_not] and matchers)}
s.email = %q{dchelimsky@gmail.com;chad.humphries@gmail.com}
s.extra_rdoc_files = [
@@ -35,6 +35,7 @@ Gem::Specification.new do |s|
"features/matchers/expect_change.feature",
"features/matchers/expect_error.feature",
"features/support/env.rb",
+ "lib/rspec-expectations.rb",
"lib/rspec/expectations.rb",
"lib/rspec/expectations/backward_compatibility.rb",
"lib/rspec/expectations/differ.rb",
@@ -117,7 +118,7 @@ Gem::Specification.new do |s|
s.rdoc_options = ["--charset=UTF-8"]
s.require_paths = ["lib"]
s.rubyforge_project = %q{rspec}
- s.rubygems_version = %q{1.3.7}
+ s.rubygems_version = %q{1.3.6}
s.summary = %q{rspec-expectations-2.0.0.beta.12}
s.test_files = [
"spec/rspec/expectations/differ_spec.rb",
@@ -157,7 +158,7 @@ Gem::Specification.new do |s|
current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 3
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
+ if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<diff-lcs>, [">= 1.1.2"])
s.add_development_dependency(%q<cucumber>, [">= 0.6.2"])
s.add_development_dependency(%q<aruba>, [">= 0.1.1"])

0 comments on commit 32cc890

Please sign in to comment.
Something went wrong with that request. Please try again.