Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

can't use 1.9 hash syntax in specs (still support 1.8) - #135

  • Loading branch information...
commit 5bdf4b82c9f5cb639964bb6b2419518d641d170e 1 parent 3591cd2
@dchelimsky dchelimsky authored
Showing with 2 additions and 2 deletions.
  1. +2 −2 spec/rspec/matchers/start_with_end_with_spec.rb
View
4 spec/rspec/matchers/start_with_end_with_spec.rb
@@ -44,7 +44,7 @@
context "with a hash" do
it "raises an ArgumentError if trying to match more than one element" do
expect{
- {a: 'b', b: 'b', c: 'c'}.should start_with({a: 'b', b: 'b'})
+ {:a => 'b', :b => 'b', :c => 'c'}.should start_with({:a => 'b', :b => 'b'})
}.to raise_error(ArgumentError, /does not have ordered elements/)
end
end
@@ -130,7 +130,7 @@
context "with a hash" do
it "raises an ArgumentError if trying to match more than one element" do
expect{
- {a: 'b', b: 'b', c: 'c'}.should end_with({a: 'b', b: 'b'})
+ {:a => 'b', :b => 'b', :c => 'c'}.should end_with({:a => 'b', :b =>'b'})
}.to raise_error(ArgumentError, /does not have ordered elements/)
end
end
Please sign in to comment.
Something went wrong with that request. Please try again.