Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Merge pull request #239 from JonRowe/upgrade_to_diff_lcs_122

Upgrade to diff-lcs 1.2.3
  • Loading branch information...
commit 6ae72a6749c2239f2f8a56fafc3a2f290cec2564 2 parents 0934b6f + 2f9dea2
@JonRowe JonRowe authored
Showing with 4 additions and 5 deletions.
  1. +4 −5 spec/rspec/expectations/differ_spec.rb
View
9 spec/rspec/expectations/differ_spec.rb
@@ -39,18 +39,17 @@ module Expectations
end
if RUBY_VERSION.to_f > 1.9
- it 'copes with encoded strings' do
- pending "awaiting patch on diff-lcs"
+ it 'copes with encoded strings', :pending => (Diff::LCS::VERSION < '1.2.2') do
@expected="Tu avec carté {count} itém has".encode('UTF-16LE')
@actual="Tu avec carte {count} item has".encode('UTF-16LE')
expect(subject).to eql(<<-EOD.encode('UTF-16LE'))
@@ -1,2 +1,2 @@
--Tu avec carté {count} itém has
-+Tu avec carte {count} item has
+-Tu avec carte {count} item has
++Tu avec carté {count} itém has
EOD
end
- it 'copes with encoded strings' do
+ it 'copes with encoded strings', :pending => (Diff::LCS::VERSION >= '1.2.2') do
@expected="Tu avec carté {count} itém has".encode('UTF-16LE')
@actual="Tu avec carte {count} item has".encode('UTF-16LE')
expect(subject).to eql 'Could not produce a diff because of the encoding of the string (UTF-16LE)'
Please sign in to comment.
Something went wrong with that request. Please try again.