Permalink
Browse files

ci: exclude local dev gems from travis bundle

  • Loading branch information...
1 parent d7d87d8 commit fe10f0b879e92a3c4a07c416ae970167bc121563 @dchelimsky dchelimsky committed Jun 21, 2011
Showing with 21 additions and 17 deletions.
  1. +1 −0 .travis.yml
  2. +20 −17 Gemfile
View
1 .travis.yml
@@ -1,4 +1,5 @@
script: "bin/rake --trace 2>&1"
+bundler_args: "--without development"
rvm:
- 1.8.6
- 1.8.7
View
37 Gemfile
@@ -14,27 +14,30 @@ end
gem "rake", "~> 0.9"
gem "cucumber", "~> 0.10.2"
gem "aruba", "~> 0.3.6"
-gem "rcov", "0.9.9", :platforms => :mri
-gem "relish", "0.4.0"
-gem "guard-rspec", "0.1.9"
-gem "growl", "1.0.3"
gem "nokogiri", "1.4.4"
-platforms :mri_18 do
- gem 'ruby-debug'
+platforms :jruby do
+ gem "jruby-openssl"
end
-platforms :mri_19 do
- gem 'linecache19', '0.5.11' # 0.5.12 cannot install on 1.9.1, and 0.5.11 appears to work with both 1.9.1 & 1.9.2
- gem 'ruby-debug19'
- gem 'ruby-debug-base19', RUBY_VERSION == '1.9.1' ? '0.11.23' : '~> 0.11.24'
-end
+group :development do
+ gem "rcov", "0.9.9", :platforms => :mri
+ gem "relish", "0.4.0"
+ gem "guard-rspec", "0.1.9"
+ gem "growl", "1.0.3"
-platforms :mri_18, :mri_19 do
- gem "rb-fsevent", "~> 0.3.9"
- gem "ruby-prof", "~> 0.9.2"
-end
+ platforms :mri_18 do
+ gem 'ruby-debug'
+ end
-platforms :jruby do
- gem "jruby-openssl"
+ platforms :mri_19 do
+ gem 'linecache19', '0.5.11' # 0.5.12 cannot install on 1.9.1, and 0.5.11 appears to work with both 1.9.1 & 1.9.2
+ gem 'ruby-debug19'
+ gem 'ruby-debug-base19', RUBY_VERSION == '1.9.1' ? '0.11.23' : '~> 0.11.24'
+ end
+
+ platforms :mri_18, :mri_19 do
+ gem "rb-fsevent", "~> 0.3.9"
+ gem "ruby-prof", "~> 0.9.2"
+ end
end

0 comments on commit fe10f0b

Please sign in to comment.