running include.feature w/1.8.7 gives error #48

Closed
kchien opened this Issue Dec 10, 2010 · 4 comments

Projects

None yet

2 participants

@kchien

With Ruby 1.8.7, all of the features pass except for include.feature. In include.feature, when it checks the output, two cases are failing:
1) expected {:a=>7, :b=>5} to include {:a=>7, :d=>3}

2) expected {:a=>7, :b=>5} not to include {:a=>7, :d=>3}

Link to patch: https://gist.github.com/735568

@dchelimsky
RSpec member

Thanks. The patch doesn't have a proper author name for you. If you'd your name in the commit log, please either recreate the patch using "git format-patch" or fork the repo and submit a proper pull request. Otherwise I'll just add your username to the history file, but it won't be in the commit log.

@kchien

Ok, I'll resubmit the patch when I get home from work.

@kchien

I modified the gist to include the new patch.

@kchien

Changed expectation to use regex.

@kchien kchien added a commit to kchien/rspec-expectations that referenced this issue Mar 7, 2014
@kchien kchien Changed expectation to use regex.
- Closes #48.
2764780
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment