Provides RSpec 3 support for formatters written against the RSpec 2.x API
Ruby Gherkin Shell
Switch branches/tags
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
features
lib/rspec
script
smoke_specs
spec
.gitignore
.rspec
.travis.yml
.yardopts
Changelog.md
Gemfile
License.txt
README.md
Rakefile
cucumber.yml
maintenance-branch
rspec-legacy_formatters.gemspec

README.md

RSpec::LegacyFormatters

This gem provides support for using legacy formatters (that is, those that were written against the RSpec 2 formatter API) with RSpec 3.

Installation

Add this line to your application's Gemfile:

gem 'rspec-legacy_formatters'

And then execute:

$ bundle

Or install it yourself as:

$ gem install rspec-legacy_formatters

Usage

This gem MUST be required before the legacy formatter is loaded. We recommend you use RSpec's --require option, either from the command line:

$ rspec --require rspec/legacy_formatters --format MyCustomFormatter

...or by adding it to .rspec:

--require rspec/legacy_formatters

Contributing

  1. Fork it ( http://github.com/rspec/rspec-legacy_formatters/fork )
  2. Create your feature branch (git checkout -b my-new-feature)
  3. Commit your changes (git commit -am 'Add some feature')
  4. Push to the branch (git push origin my-new-feature)
  5. Create new Pull Request