Skip to content
This repository
Browse code

update Gemfile to address build issues with 1.9.1

  • Loading branch information...
commit 3e315966397582c4ca18792adacd92e4a8554c4c 1 parent ca9c16b
David Chelimsky authored April 10, 2011

Showing 1 changed file with 10 additions and 9 deletions. Show diff stats Hide diff stats

  1. 19  Gemfile
19  Gemfile
@@ -14,21 +14,23 @@ end
14 14
 gem "rake", "0.8.7"
15 15
 gem "cucumber", "~> 0.10.2"
16 16
 gem "aruba", "~> 0.3.5"
17  
-gem "rcov", "0.9.9"
  17
+gem "rcov", "0.9.9", :platforms => :mri
18 18
 gem "relish", "0.2.0"
19 19
 gem "guard-rspec", "0.1.9"
20 20
 gem "growl", "1.0.3"
21  
-gem "ZenTest", "~> 4.4.2"
  21
+gem "nokogiri", "1.4.4"
22 22
 
23  
-if RUBY_PLATFORM =~ /darwin/
24  
-  gem "autotest-fsevent", "~> 0.2.4"
25  
-  gem "autotest-growl", "~> 0.2.9"
  23
+platforms :mri_18 do
  24
+  gem 'ruby-debug'
26 25
 end
27 26
 
28  
-gem "ruby-debug", :platforms => :ruby_18
29  
-gem "ruby-debug19", "~> 0.11.6", :platforms => :ruby_19
  27
+platforms :mri_19 do
  28
+  gem 'linecache19', '0.5.11' # 0.5.12 cannot install on 1.9.1, and 0.5.11 appears to work with both 1.9.1 & 1.9.2
  29
+  gem 'ruby-debug19'
  30
+  gem 'ruby-debug-base19', RUBY_VERSION == '1.9.1' ? '0.11.23' : '~> 0.11.24'
  31
+end
30 32
 
31  
-platforms :ruby_18, :ruby_19 do
  33
+platforms :mri_18, :mri_19 do
32 34
   gem "rb-fsevent", "~> 0.3.9"
33 35
   gem "ruby-prof", "~> 0.9.2"
34 36
 end
@@ -36,4 +38,3 @@ end
36 38
 platforms :jruby do
37 39
   gem "jruby-openssl"
38 40
 end
39  
-

0 notes on commit 3e31596

Please sign in to comment.
Something went wrong with that request. Please try again.