Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 43 lines (31 sloc) 1.114 kb
32c8f5a @vfrride Uses secure RubyGems URL
vfrride authored
1 source "https://rubygems.org"
5687b8d @dchelimsky dev: much simpler management of multiple gemfiles
dchelimsky authored
2
e1fd5b6 @dchelimsky dev: align Gemfiles across rspec projects
dchelimsky authored
3 gemspec
4
30220b0 @cupakromer Move common rspec dependencies into custom Gemfile
cupakromer authored
5 rspec_dependencies_gemfile = File.expand_path("../Gemfile-rspec-dependencies", __FILE__)
6 eval_gemfile rspec_dependencies_gemfile
5687b8d @dchelimsky dev: much simpler management of multiple gemfiles
dchelimsky authored
7
e1fd5b6 @dchelimsky dev: align Gemfiles across rspec projects
dchelimsky authored
8 ### deps for rdoc.info
171f869 @alindeman Reduces time needed to install/compile gems on @travis-ci
alindeman authored
9 group :documentation do
ddd8a6c @alindeman Bumps yard and related dependencies
alindeman authored
10 gem 'yard', '0.8.7.3', :require => false
11 gem 'redcarpet', '2.3.0'
12 gem 'github-markup', '1.0.0'
171f869 @alindeman Reduces time needed to install/compile gems on @travis-ci
alindeman authored
13 end
e1fd5b6 @dchelimsky dev: align Gemfiles across rspec projects
dchelimsky authored
14
40d3bf1 @dchelimsky constrain ammeter dependency to :test group
dchelimsky authored
15 platforms :jruby do
16 gem "jruby-openssl"
17 end
18
f03065c @dchelimsky dev: update Gemfile
dchelimsky authored
19 gem 'sqlite3', '~> 1.3.6'
5687b8d @dchelimsky dev: much simpler management of multiple gemfiles
dchelimsky authored
20
1ae04fb @alindeman We can only test rspec-rails 3 with capybara on 1.9.3 and above
alindeman authored
21 # Capybara versions that support RSpec 3 only support RUBY_VERSION >= 1.9.3
22 if RUBY_VERSION >= '1.9.3'
fbbe1e2 @cupakromer Handle feature specs without Capybara.
cupakromer authored
23 gem 'capybara', '~> 2.2.0', :require => false
3e2b5b5 @alindeman Capybara 2.1 cannot be used with Ruby < 1.9.3
alindeman authored
24 end
25
4ebbe12 @soulcutter Fix nokogiri dependency to 1.5.x for ruby 1.8.7
soulcutter authored
26 if RUBY_VERSION < '1.9.2'
27 gem 'nokogiri', '~> 1.5.0'
28 end
29
f0b5cf8 @alindeman Works around 1.8.7 error with rubyzip: https://travis-ci.org/rspec/rspec...
alindeman authored
30 if RUBY_VERSION <= '1.8.7'
31 # cucumber and gherkin require rubyzip as a runtime dependency on 1.8.7
32 # Only < 1.0 supports 1.8.7
33 gem 'rubyzip', '< 1.0'
34 end
35
f6c277f @cupakromer Add Rubocop style standards to build.
cupakromer authored
36 gem 'rubocop', "~> 0.23.0", :platform => [:ruby_19, :ruby_20, :ruby_21]
37
10de3e3 @dchelimsky dev: fix inclusion of custom Gemfile
dchelimsky authored
38 custom_gemfile = File.expand_path("../Gemfile-custom", __FILE__)
30220b0 @cupakromer Move common rspec dependencies into custom Gemfile
cupakromer authored
39 eval_gemfile custom_gemfile if File.exist?(custom_gemfile)
5687b8d @dchelimsky dev: much simpler management of multiple gemfiles
dchelimsky authored
40
eb4da76 @cupakromer Extract rails gem loading into shared Gemfile.
cupakromer authored
41 rails_dependencies_gemfile = File.expand_path("../Gemfile-rails-dependencies", __FILE__)
42 eval_gemfile rails_dependencies_gemfile
Something went wrong with that request. Please try again.