Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 39 lines (33 sloc) 1.557 kb
02894f1 @dchelimsky store gemspec in git
dchelimsky authored
1 # -*- encoding: utf-8 -*-
5d74242 @myronmarston Remove dependency on jeweler.
myronmarston authored
2 $LOAD_PATH.unshift File.expand_path("../lib", __FILE__)
3 require "rspec/rails/version"
02894f1 @dchelimsky store gemspec in git
dchelimsky authored
4
5 Gem::Specification.new do |s|
5d74242 @myronmarston Remove dependency on jeweler.
myronmarston authored
6 s.name = "rspec-rails"
7 s.version = RSpec::Rails::Version::STRING
8 s.platform = Gem::Platform::RUBY
c954554 @dchelimsky add license to gemspec (and consequently the gem)
dchelimsky authored
9 s.license = "MIT"
bcb4ba6 @dchelimsky Add License
dchelimsky authored
10 s.authors = ["David Chelimsky"]
08ceb6f @dchelimsky update email addy and homepage in gemspec
dchelimsky authored
11 s.email = "rspec-users@rubyforge.org"
5d74242 @myronmarston Remove dependency on jeweler.
myronmarston authored
12 s.homepage = "http://github.com/rspec/rspec-rails"
13 s.summary = "rspec-rails-#{RSpec::Rails::Version::STRING}"
3efe8f9 @dchelimsky ci: add rails 3-2-stable and fix support for rails master
dchelimsky authored
14 s.description = "RSpec for Rails"
5d74242 @myronmarston Remove dependency on jeweler.
myronmarston authored
15
16 s.rubyforge_project = "rspec"
17
eb9f887 @dchelimsky dev: constrain file list in gemspec
dchelimsky authored
18 s.files = `git ls-files -- lib/*`.split("\n")
5f9b860 @dchelimsky align gemspec with other rspec libs
dchelimsky authored
19 s.files += %w[README.md License.txt Changelog.md .yardopts .document]
5d74242 @myronmarston Remove dependency on jeweler.
myronmarston authored
20 s.test_files = `git ls-files -- {spec,features}/*`.split("\n")
21 s.rdoc_options = ["--charset=UTF-8"]
22 s.require_path = "lib"
23
3efe8f9 @dchelimsky ci: add rails 3-2-stable and fix support for rails master
dchelimsky authored
24 s.add_runtime_dependency(%q<activesupport>, [">= 3.0"])
25 s.add_runtime_dependency(%q<actionpack>, [">= 3.0"])
26 s.add_runtime_dependency(%q<railties>, [">= 3.0"])
aea643f @dchelimsky bump to 2.7.0.rc1
dchelimsky authored
27 if RSpec::Rails::Version::STRING =~ /[a-zA-Z]+/ # prerelease builds
28 s.add_runtime_dependency "rspec", "= #{RSpec::Rails::Version::STRING}"
29 else
421ff03 @dchelimsky don't depend on yourself, silly
dchelimsky authored
30 s.add_runtime_dependency "rspec", "~> #{RSpec::Rails::Version::STRING.split('.')[0..1].concat(['0']).join('.')}"
aea643f @dchelimsky bump to 2.7.0.rc1
dchelimsky authored
31 end
e1fd5b6 @dchelimsky dev: align Gemfiles across rspec projects
dchelimsky authored
32
33 s.add_development_dependency 'rake', '~> 0.9.2'
34 s.add_development_dependency 'cucumber', '~> 1.1.9'
35 s.add_development_dependency 'aruba', '~> 0.4.11'
36 s.add_development_dependency 'ZenTest', '4.6.2'
b6e3ae3 @dchelimsky dev: bump ammeter to 0.2.5
dchelimsky authored
37 s.add_development_dependency 'ammeter', '0.2.5'
02894f1 @dchelimsky store gemspec in git
dchelimsky authored
38 end
Something went wrong with that request. Please try again.