Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 35 lines (29 sloc) 1.315 kb
02894f1 @dchelimsky store gemspec in git
dchelimsky authored
1 # -*- encoding: utf-8 -*-
5d74242 @myronmarston Remove dependency on jeweler.
myronmarston authored
2 $LOAD_PATH.unshift File.expand_path("../lib", __FILE__)
3 require "rspec/rails/version"
02894f1 @dchelimsky store gemspec in git
dchelimsky authored
4
5 Gem::Specification.new do |s|
5d74242 @myronmarston Remove dependency on jeweler.
myronmarston authored
6 s.name = "rspec-rails"
7 s.version = RSpec::Rails::Version::STRING
8 s.platform = Gem::Platform::RUBY
bcb4ba6 @dchelimsky Add License
dchelimsky authored
9 s.authors = ["David Chelimsky"]
10 s.email = "dchelimsky@gmail.com"
5d74242 @myronmarston Remove dependency on jeweler.
myronmarston authored
11 s.homepage = "http://github.com/rspec/rspec-rails"
12 s.summary = "rspec-rails-#{RSpec::Rails::Version::STRING}"
13 s.description = "RSpec-2 for Rails-3"
14
15 s.rubygems_version = "1.3.7"
16 s.rubyforge_project = "rspec"
17
18 s.files = `git ls-files`.split("\n")
19 s.test_files = `git ls-files -- {spec,features}/*`.split("\n")
20 s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
3025e80 @dchelimsky bump version to 2.2
dchelimsky authored
21 s.extra_rdoc_files = [ "README.md" ]
5d74242 @myronmarston Remove dependency on jeweler.
myronmarston authored
22 s.rdoc_options = ["--charset=UTF-8"]
23 s.require_path = "lib"
24
9bb8406 @dchelimsky Make rails gem deps work for anything < 4.0
dchelimsky authored
25 s.add_runtime_dependency(%q<activesupport>, ["~> 3.0"])
26 s.add_runtime_dependency(%q<actionpack>, ["~> 3.0"])
27 s.add_runtime_dependency(%q<railties>, ["~> 3.0"])
cd45332 @dchelimsky prep for 2.6.0.rc1
dchelimsky authored
28 if RSpec::Rails::Version::STRING =~ /[a-zA-Z]+/
421ff03 @dchelimsky don't depend on yourself, silly
dchelimsky authored
29 s.add_runtime_dependency "rspec", "= #{RSpec::Rails::Version::STRING}"
cd45332 @dchelimsky prep for 2.6.0.rc1
dchelimsky authored
30 else
421ff03 @dchelimsky don't depend on yourself, silly
dchelimsky authored
31 s.add_runtime_dependency "rspec", "~> #{RSpec::Rails::Version::STRING.split('.')[0..1].concat(['0']).join('.')}"
cd45332 @dchelimsky prep for 2.6.0.rc1
dchelimsky authored
32 end
02894f1 @dchelimsky store gemspec in git
dchelimsky authored
33 end
34
Something went wrong with that request. Please try again.