Skip to content
This repository
Fetching contributors…

Octocat-spinner-32-eaf2f5

Cannot retrieve contributors at this time

file 66 lines (48 sloc) 2.384 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65
# -*- encoding: utf-8 -*-
$LOAD_PATH.unshift File.expand_path("../lib", __FILE__)
require "rspec/rails/version"

Gem::Specification.new do |s|
  s.name = "rspec-rails"
  s.version = RSpec::Rails::Version::STRING
  s.platform = Gem::Platform::RUBY
  s.authors = ["David Chelimsky"]
  s.email = "dchelimsky@gmail.com"
  s.homepage = "http://github.com/rspec/rspec-rails"
  s.summary = "rspec-rails-#{RSpec::Rails::Version::STRING}"
  s.description = "RSpec-2 for Rails-3"

  s.rubygems_version = "1.3.7"
  s.rubyforge_project = "rspec"

  s.files = `git ls-files`.split("\n")
  s.test_files = `git ls-files -- {spec,features}/*`.split("\n")
  s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
  s.extra_rdoc_files = [ "README.md" ]
  s.rdoc_options = ["--charset=UTF-8"]
  s.require_path = "lib"

  s.post_install_message = %Q{**************************************************

Thank you for installing #{s.summary}!

This version of rspec-rails only works with versions of rails >= 3.0.0

To configure your app to use rspec-rails, add a declaration to your Gemfile.
If you are using Bundler's grouping feature in your Gemfile, be sure to include
rspec-rails in the :development group as well as the :test group so that you
can access its generators and rake tasks.

group :development, :test do
gem "rspec-rails", ">= #{RSpec::Rails::Version::STRING}"
end

Be sure to run the following command in each of your Rails apps if you're
upgrading:

script/rails generate rspec:install

Even if you've run it before, this ensures that you have the latest updates
to spec/spec_helper.rb and any other support files.

Beta versions of rspec-rails-2 installed files that are no longer being used,
so please remove these files if you have them:

lib/tasks/rspec.rake
config/initializers/rspec_generator.rb

Lastly, be sure to look at Upgrade.markdown to see what might have changed
since the last release.

**************************************************
}

  s.add_runtime_dependency(%q<activesupport>, ["~> 3.0"])
  s.add_runtime_dependency(%q<actionpack>, ["~> 3.0"])
  s.add_runtime_dependency(%q<railties>, ["~> 3.0"])
  s.add_runtime_dependency "rspec", "~> #{RSpec::Rails::Version::STRING.split('.')[0..1].concat(['0']).join('.')}"
end

Something went wrong with that request. Please try again.