Permalink
Browse files

exclude dev-only gems for builds on travis

  • Loading branch information...
1 parent 52012b8 commit 792afc323069b52955e8790a9db2505c95681445 @dchelimsky dchelimsky committed Apr 24, 2011
Showing with 23 additions and 12 deletions.
  1. +1 −0 .travis.yml
  2. +22 −12 gemfiles/base.rb
View
@@ -9,3 +9,4 @@ gemfile:
- "$PWD/gemfiles/rails-master"
env:
- USE_GIT_REPOS=true
+ - CI=true
View
@@ -17,24 +17,34 @@ def self.extended(host)
gem 'sqlite3-ruby', :require => 'sqlite3'
gem "cucumber", "~> 0.10.2"
gem "aruba", "~> 0.3.6"
- gem "rcov", "0.9.9"
- gem "relish", "0.2.0"
- gem "guard-rspec", "0.1.9"
gem "growl", "1.0.3"
gem "ZenTest", "~> 4.4.2"
gem "webrat", "0.7.2"
- if RUBY_PLATFORM =~ /darwin/
- gem "autotest-fsevent", "~> 0.2.4"
- gem "autotest-growl", "~> 0.2.9"
- end
+ unless ENV['CI']
+ gem "rcov", "0.9.9"
+ gem "relish", "0.2.0"
+ gem "guard-rspec", "0.1.9"
+
+ if RUBY_PLATFORM =~ /darwin/
+ gem "autotest-fsevent", "~> 0.2.4"
+ gem "autotest-growl", "~> 0.2.9"
+ end
- gem "ruby-debug", :platforms => :ruby_18
- gem "ruby-debug19", "~> 0.11.6", :platforms => :ruby_19
+ platforms :mri_18 do
+ gem 'ruby-debug'
+ end
- platforms :ruby_18, :ruby_19 do
- gem "rb-fsevent", "~> 0.3.9"
- gem "ruby-prof", "~> 0.9.2"
+ platforms :mri_19 do
+ gem 'linecache19', '0.5.11' # 0.5.12 cannot install on 1.9.1, and 0.5.11 appears to work with both 1.9.1 & 1.9.2
+ gem 'ruby-debug19'
+ gem 'ruby-debug-base19', RUBY_VERSION == '1.9.1' ? '0.11.23' : '~> 0.11.24'
+ end
+
+ platforms :ruby_18, :ruby_19 do
+ gem "rb-fsevent", "~> 0.3.9"
+ gem "ruby-prof", "~> 0.9.2"
+ end
end
platforms :jruby do

0 comments on commit 792afc3

Please sign in to comment.