Permalink
Browse files

Capybara 2.2.0 is required

Resolves #860
  • Loading branch information...
1 parent c0b2d53 commit 8254ddc10c8e34912300ca2c8df275cc5132d1ba @alindeman alindeman committed Feb 10, 2014
Showing with 5 additions and 2 deletions.
  1. +1 −1 Gemfile
  2. +3 −0 lib/rspec/rails/vendor/capybara.rb
  3. +1 −1 rspec-rails.gemspec
View
@@ -26,7 +26,7 @@ gem 'sqlite3', '~> 1.3.6'
# Capybara versions that support RSpec 3 only support RUBY_VERSION >= 1.9.3
if RUBY_VERSION >= '1.9.3'
- gem 'capybara', :github => 'jnicklas/capybara'
+ gem 'capybara', '2.2.0'
end
if RUBY_VERSION < '1.9.2'
@@ -9,6 +9,9 @@
end
if defined?(Capybara)
+ require 'rspec/support/version_checker'
+ RSpec::Support::VersionChecker.new('capybara', Capybara::VERSION, '2.2.0')
+
RSpec.configure do |c|
if defined?(Capybara::DSL)
c.include Capybara::DSL, :type => :feature
View
@@ -31,7 +31,7 @@ Gem::Specification.new do |s|
s.add_runtime_dependency(%q<activemodel>, [">= 3.0"])
s.add_runtime_dependency(%q<actionpack>, [">= 3.0"])
s.add_runtime_dependency(%q<railties>, [">= 3.0"])
- %w[core expectations mocks].each do |name|
+ %w[core expectations mocks support].each do |name|
if RSpec::Rails::Version::STRING =~ /[a-zA-Z]+/ # prerelease builds
s.add_runtime_dependency "rspec-#{name}", "= #{RSpec::Rails::Version::STRING}"
else

0 comments on commit 8254ddc

Please sign in to comment.