Permalink
Browse files

Restore the dependencies on the rails gems to ~> 3.0, which includes any

rails < 4.0.

This reverts commit 7d4c1fc.
  • Loading branch information...
1 parent 58b7d20 commit 90dff2034e8847858bb552001142e7a75de92b42 @dchelimsky dchelimsky committed May 6, 2011
Showing with 3 additions and 4 deletions.
  1. +0 −1 features/Changelog.md
  2. +3 −3 rspec-rails.gemspec
View
@@ -4,7 +4,6 @@
* Bug fixes
* Fix load order issue w/ Capybara (oleg dashevskii)
- * Relax the dependencies on rails gems to >= 3.0 (Joel Moss)
* Fix monkey patches that broke due to internal changes in rails-3.1.0.beta1
### 2.6.0.rc4 / 2011-05-01
View
@@ -22,9 +22,9 @@ Gem::Specification.new do |s|
s.rdoc_options = ["--charset=UTF-8"]
s.require_path = "lib"
- s.add_runtime_dependency(%q<activesupport>, [">= 3.0"])
- s.add_runtime_dependency(%q<actionpack>, [">= 3.0"])
- s.add_runtime_dependency(%q<railties>, [">= 3.0"])
+ s.add_runtime_dependency(%q<activesupport>, ["~> 3.0"])
+ s.add_runtime_dependency(%q<actionpack>, ["~> 3.0"])
+ s.add_runtime_dependency(%q<railties>, ["~> 3.0"])
if RSpec::Rails::Version::STRING =~ /[a-zA-Z]+/
s.add_runtime_dependency "rspec", "= #{RSpec::Rails::Version::STRING}"
else

0 comments on commit 90dff20

Please sign in to comment.