Permalink
Browse files

Require minitest for rails >= 4.1.0

  • Loading branch information...
1 parent 2d21e67 commit a5a04b674b2b0f9c4f8bb0edf06969035eefe713 @vanstee vanstee committed with alindeman Jul 25, 2013
Showing with 8 additions and 2 deletions.
  1. +8 −2 lib/rspec/rails/adapters.rb
@@ -4,8 +4,14 @@
module RSpec
module Rails
module Assertions
- require 'test/unit/assertions'
- include Test::Unit::Assertions
+ if ::Rails::VERSION::STRING >= '4.1.0'
+ gem 'minitest'
+ require 'minitest/assertions'
+ include Minitest::Assertions
+ else
+ require 'test/unit/assertions'
+ include Test::Unit::Assertions
+ end
end
class AssertionDelegator < Module

0 comments on commit a5a04b6

Please sign in to comment.