Permalink
Browse files

require "active_support" is always needed

Per <rails/rails#13605 (comment)>,
always load the base "active_support" file before loading specific parts
of active_support.
  • Loading branch information...
1 parent e45fb6f commit c0b2d5380979d77194a742f0c82389e9572929bc @alindeman alindeman committed Jan 6, 2014
View
1 Changelog.md
@@ -7,6 +7,7 @@ Bug fixes
* Supports Rails 4.1. (Andy Lindeman)
* Routes are drawn correctly for anonymous controllers with abstract
parents. (Billy Chan)
+* Loads ActiveSupport properly to support changes in Rails 4.1. (Andy Lindeman)
Enhancements
View
1 lib/rspec/rails/adapters.rb
@@ -1,4 +1,5 @@
require 'delegate'
+require 'active_support'
require 'active_support/concern'
module RSpec
View
1 lib/rspec/rails/mocks.rb
@@ -1,3 +1,4 @@
+require 'active_support'
require 'active_support/core_ext'
require 'active_model'
View
1 spec/rspec/rails/matchers/be_valid_spec.rb
@@ -1,5 +1,4 @@
require "spec_helper"
-require 'active_support/all'
require 'rspec/rails/matchers/be_valid'
describe "be_valid matcher" do
View
1 spec/rspec/rails/matchers/redirect_to_spec.rb
@@ -1,4 +1,5 @@
require "spec_helper"
+require "active_support"
require "active_support/test_case"
describe "redirect_to" do

0 comments on commit c0b2d53

Please sign in to comment.