Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

dev: align Gemfiles across rspec projects

  • Loading branch information...
commit e1fd5b608d5caae1fe75a80ebe8d38eece877240 1 parent d691d05
@dchelimsky dchelimsky authored
Showing with 23 additions and 28 deletions.
  1. +8 −10 Gemfile
  2. +9 −18 Gemfile-custom.sample
  3. +6 −0 rspec-rails.gemspec
View
18 Gemfile
@@ -1,6 +1,8 @@
source "http://rubygems.org"
-%w[rspec rspec-core rspec-expectations rspec-mocks rspec-rails].each do |lib|
+gemspec
+
+%w[rspec rspec-core rspec-expectations rspec-mocks].each do |lib|
library_path = File.expand_path("../../#{lib}", __FILE__)
if File.exist?(library_path)
gem lib, :path => library_path
@@ -11,20 +13,16 @@ source "http://rubygems.org"
end
end
+### deps for rdoc.info
+gem 'yard', '0.7.5', :require => false
+gem 'redcarpet', '2.1.1'
+gem 'github-markup', '0.7.2'
+
platforms :jruby do
gem "jruby-openssl"
end
gem 'sqlite3', '~> 1.3.6'
-gem 'rake', '~> 0.9.2'
-gem 'rdoc'
-
-group :development, :test do
- gem 'cucumber', '1.1.9'
- gem 'aruba', '0.4.11'
- gem 'ZenTest', '4.6.2'
- gem 'ammeter', '0.2.4'
-end
eval File.read('Gemfile-custom') if File.exist?('Gemfile-custom')
View
27 Gemfile-custom.sample
@@ -1,21 +1,17 @@
group :development do
gem 'interactive_rspec'
- gem 'yard', "~> 0.7.4"
- gem "relish", "~> 0.5.0"
- gem "guard-rspec", "0.5.0"
- gem "growl", "1.0.3"
- gem "spork", "0.9.0"
+ gem 'relish', '~> 0.5.0'
+ gem 'guard-rspec', '0.5.0'
+ gem 'growl', '1.0.3'
+ gem 'spork', '0.9.0'
- platforms :mri_18, :jruby do
- gem "rcov", "0.9.10"
- end
-
- platforms :mri_18 do
- gem 'ruby-debug'
- end
+ platform :mri do
+ gem 'rb-fsevent', '~> 0.4.3.1'
+ gem 'ruby-prof', '~> 0.10.0'
- platforms :mri_19 do
case RUBY_VERSION
+ when /^1.8/
+ gem 'ruby-debug'
when '1.9.2'
gem 'ruby-debug19', '0.11.6'
gem 'ruby-debug-base19', '0.11.25'
@@ -35,9 +31,4 @@ group :development do
gem 'linecache19', '0.5.13'
end
end
-
- platforms :mri_18, :mri_19 do
- gem "rb-fsevent", "~> 0.4.3.1"
- gem "ruby-prof", "~> 0.10.0"
- end
end
View
6 rspec-rails.gemspec
@@ -29,4 +29,10 @@ Gem::Specification.new do |s|
else
s.add_runtime_dependency "rspec", "~> #{RSpec::Rails::Version::STRING.split('.')[0..1].concat(['0']).join('.')}"
end
+
+ s.add_development_dependency 'rake', '~> 0.9.2'
+ s.add_development_dependency 'cucumber', '~> 1.1.9'
+ s.add_development_dependency 'aruba', '~> 0.4.11'
+ s.add_development_dependency 'ZenTest', '4.6.2'
+ s.add_development_dependency 'ammeter', '0.2.4'
end
Please sign in to comment.
Something went wrong with that request. Please try again.