Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

2.3.0 rspec:install failure on autotest directory copy #283

Closed
adamaig opened this Issue Dec 13, 2010 · 6 comments

Comments

Projects
None yet
6 participants

adamaig commented Dec 13, 2010

Rspec::Generators::InstallGenerator::copy_autotest_files fails now because there is no autotest directory in the templates directory in the gem after discover.rb was removed.

This is preventing the generator from completing the install task.

A quick solution for those with this problem is to make the missing directory in the gem. (i.e., mkdir rspec-rails-2.3.0/lib/generators/rspec/install/templates/autotest )

I'm having the same issue as @adamaig. The output I'm having is:

Could not find "autotest" in any of your source paths. Your current source paths are: 
/projects/projectname/lib/templates/rspec/install
/Users/username/.rvm/gems/ree-1.8.7-2010.02/gems/rspec-rails-2.3.0/lib/generators/rspec/install/templates
Owner

dchelimsky commented Dec 13, 2010

Fix bug in which rspec:install generator tries to copy autotest files
that don't exist.

How do you make the missing directory in gem?

Now when I run rspec:install it doesn't install autotest at all. Should I be worried? I'm running within rvm if that helps.

Owner

dchelimsky commented Dec 30, 2010

creating autotest directory solved the problem. Thanks.

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment