rails gem deps #275

Closed
wants to merge 1 commit into
from

Projects

None yet

2 participants

@solnic
solnic commented Nov 29, 2010

Hey,

I removed dependency on the monolithic rails gem and replaced that with an explicit dependency on railties, actionpack and activesupport gems. This is what we've got in dm-rails gem because we don't want to have activerecord and arel pulled in if we're using DataMapper. It's the same case here with rspec-rails. I have an app that uses DataMapper and RSpec. I upgraded today to RSpec 2.2.0 and got active record and arel pulled in as new dependencies.

Thanks

solnic

@langalex

+1, I'm using couch potato and suddenly there's ActiveRecord, which results in the app not starting anymore because I don't have a database.yml.

@solnic
solnic commented Nov 30, 2010

Depend on railties, activesupport and actionpack instead of monolithic rails gem

This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment