Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

setup Gemfile for dev environment

  • Loading branch information...
commit 647fcdcd95002b3c14a15ed4c33ffe74a137093e 1 parent 447608c
@dchelimsky dchelimsky authored
Showing with 11 additions and 3 deletions.
  1. +5 −0 Gemfile
  2. +3 −0  Rakefile
  3. +3 −3 rspec.gemspec
View
5 Gemfile
@@ -0,0 +1,5 @@
+gem "rake"
+gem "jeweler"
+gem "rspec-core", :path => "../rspec-core"
+gem "rspec-expectations", :path => "../rspec-expectations"
+gem "rspec-mocks", :path => "../rspec-mocks"
View
3  Rakefile
@@ -1,3 +1,6 @@
+require "bundler"
+Bundler.setup
+
require 'rake'
require 'fileutils'
require 'pathname'
View
6 rspec.gemspec
@@ -9,7 +9,7 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
s.authors = ["David Chelimsky", "Chad Humphries"]
- s.date = %q{2010-06-18}
+ s.date = %q{2010-06-21}
s.description = %q{Meta-gem that depends on the other rspec gems}
s.email = %q{dchelimsky@gmail.com;chad.humphries@gmail.com}
s.extra_rdoc_files = [
@@ -41,14 +41,14 @@ Gem::Specification.new do |s|
s.rdoc_options = ["--charset=UTF-8"]
s.require_paths = ["lib"]
s.rubyforge_project = %q{rspec}
- s.rubygems_version = %q{1.3.7}
+ s.rubygems_version = %q{1.3.6}
s.summary = %q{rspec-2.0.0.beta.12}
if s.respond_to? :specification_version then
current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 3
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
+ if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<rspec-core>, ["= 2.0.0.beta.12"])
s.add_runtime_dependency(%q<rspec-expectations>, ["= 2.0.0.beta.12"])
s.add_runtime_dependency(%q<rspec-mocks>, ["= 2.0.0.beta.12"])
Please sign in to comment.
Something went wrong with that request. Please try again.