Skip to content
Browse files

move version to VERSION file

  • Loading branch information...
1 parent 61a34ff commit b9de09b662029fd470c9dbf898600135db7664af @dchelimsky dchelimsky committed Feb 20, 2010
Showing with 14 additions and 21 deletions.
  1. +1 −0 VERSION
  2. +1 −10 lib/rspec/version.rb
  3. +12 −11 rspec.gemspec
View
1 VERSION
@@ -0,0 +1 @@
+2.0.0.a7
View
11 lib/rspec/version.rb
@@ -1,14 +1,5 @@
module Rspec # :nodoc:
module Version # :nodoc:
- unless defined?(MAJOR)
- MAJOR = 2
- MINOR = 0
- TINY = 0
- PRE = 'a6'
-
- STRING = [MAJOR, MINOR, TINY, PRE].compact.join('.')
-
- SUMMARY = "rspec-meta " + STRING
- end
+ STRING = File.read(File.expand_path('../../../VERSION', __FILE__))
end
end
View
23 rspec.gemspec
@@ -5,11 +5,11 @@
Gem::Specification.new do |s|
s.name = %q{rspec}
- s.version = "2.0.0.a6"
+ s.version = "2.0.0.a7"
s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
s.authors = ["David Chelimsky", "Chad Humphries"]
- s.date = %q{2010-02-15}
+ s.date = %q{2010-02-20}
s.email = %q{dchelimsky@gmail.com;chad.humphries@gmail.com}
s.extra_rdoc_files = [
"README.markdown"
@@ -20,6 +20,7 @@ Gem::Specification.new do |s|
"License.txt",
"README.markdown",
"Rakefile",
+ "VERSION",
"lib/rspec.rb",
"lib/rspec/version.rb",
"rspec.gemspec"
@@ -36,18 +37,18 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<rspec-core>, [">= 2.0.0.a6"])
- s.add_runtime_dependency(%q<rspec-expectations>, [">= 2.0.0.a6"])
- s.add_runtime_dependency(%q<rspec-mocks>, [">= 2.0.0.a6"])
+ s.add_runtime_dependency(%q<rspec-core>, [">= 2.0.0.a7"])
+ s.add_runtime_dependency(%q<rspec-expectations>, [">= 2.0.0.a7"])
+ s.add_runtime_dependency(%q<rspec-mocks>, [">= 2.0.0.a7"])
else
- s.add_dependency(%q<rspec-core>, [">= 2.0.0.a6"])
- s.add_dependency(%q<rspec-expectations>, [">= 2.0.0.a6"])
- s.add_dependency(%q<rspec-mocks>, [">= 2.0.0.a6"])
+ s.add_dependency(%q<rspec-core>, [">= 2.0.0.a7"])
+ s.add_dependency(%q<rspec-expectations>, [">= 2.0.0.a7"])
+ s.add_dependency(%q<rspec-mocks>, [">= 2.0.0.a7"])
end
else
- s.add_dependency(%q<rspec-core>, [">= 2.0.0.a6"])
- s.add_dependency(%q<rspec-expectations>, [">= 2.0.0.a6"])
- s.add_dependency(%q<rspec-mocks>, [">= 2.0.0.a6"])
+ s.add_dependency(%q<rspec-core>, [">= 2.0.0.a7"])
+ s.add_dependency(%q<rspec-expectations>, [">= 2.0.0.a7"])
+ s.add_dependency(%q<rspec-mocks>, [">= 2.0.0.a7"])
end
end

0 comments on commit b9de09b

Please sign in to comment.
Something went wrong with that request. Please try again.