Not working on Python 3, Working Fine on python 2.7 #32

Closed
sathishmanohar opened this Issue Dec 15, 2010 · 2 comments

Comments

Projects
None yet
4 participants

Sparkup for some reason doesn't work on windows 7 with python 3.1 but If I install python 2.7, Sparkup works perfectly.

Same here when trying to expand get:

File "<path_to_vimfiles>\ftplugin\html\sparkup.py", line 949
print "Usage: %s [OPTIONS]" % sys.argv[0]
^
SyntaxError: invalid syntax

Windows 7 and Python 3.2 for x64

aignas commented Oct 1, 2012

This is because sparkup wasn't ported to Python 3. The shebang in sparkup.py files should clearly show that.

@faceleg faceleg closed this Aug 22, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment