Skip to content
This repository

expansion code failed ? #50

Open
bolasblack opened this Issue · 2 comments

3 participants

c4605 Christopher Toledo Michael Robinson
c4605

I write html:5 press C-e, then it became <html:u></html:u>

div became <diu></diu>

All code expansioned like that, the last latter became 'u' than expansioned...

Is anything i do wrong?

Christopher Toledo

I am also having this problem! Everything was fine before then I had to redo large parts of my .vimrc due to a silly mistake... and now this is happening.

bolasblack, did you figure anything out?

PS, I ran the unit tests and they seem to be passing:
[nak@arch sparkup]$ ./sparkup-unittest.py
Test results:
- Text with dot test [ OK ]
- ID and class test 2 [ OK ]
- Sibling test [ OK ]
- Attribute with dot test [ OK ]
- Multiple attributes test [ OK ]
- Attributes test [ OK ]
- Child test [ OK ]
- Child + sibling test [ OK ]
- Class test [ OK ]
- Expand test [ OK ]
- Back test [ OK ]
- ID and class test [ OK ]
- Menu test [ OK ]
- Shortcut test [ OK ]
- Simple test [ OK ]
- Ampersand test [ OK ]
- Multiple class test [ OK ]
- Multiplier test 2 [ OK ]
- Multiplier test 3 [ OK ]
- Shortcut synonym test [ OK ]
- Multiplier test 1 [ OK ]

I also have to change the hash-bang line to point to python2.7 since arch defaults to python3

Michael Robinson
Collaborator

I've been noticing this as well.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.