Sparkup suddenly behaves incorrectly #64

Closed
romainl opened this Issue Sep 6, 2012 · 1 comment

1 participant

@romainl

Hi! I've been using Sparkup extensively in Vim (and in TextMate before) for over one year and a half without any issue.

My primary use for Sparkup is (alas!) coding HTML emails which involves a lot of nested tables.

Well. I've been lucky enough to not do any HTML emails in the last month so I'm not sure when it happened but Sparkup now does something quite weird: whatever stub I use (a,p,table…), the final tag is always a div. For example:

p

would become:

<div></div>

To make things even weirder, the problem only happens on the first tag:

p > span{lorem ipsum}

would become:

<div>
  <span>lorem ipsum</span>
</div>

The issue remains:

  • with or without any of my plugins
  • with or without any of my ftplugins
  • with or without any of my settings
  • with or without any of my mappings
  • with or without any of my custom functions
  • when installing Sparkup "normally" (without Pathogen)

My system:

  • Mac OS X 10.6.8
  • Vim 7.3.315 and the default Vim 7.2.108
  • Python 2.7.3 (via MacPorts)

My Vim files:

FYI, I don't experience the issue on a VPS of mine or my Ubuntu machine at home using a clone of the repo above:

  • Ubuntu 10.04 LTS and 11.04
  • Vim 7.2.330 and Vim 7.3.35
  • Python 2.6.5 and Python 2.7.1

Thanks.

@romainl

I resolved the issue by switching Python versions:

$ sudo port select python python26-apple 
@romainl romainl closed this Sep 7, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment