Permalink
Browse files

add debian dependencies no longer included with later versions of ubuntu

  • Loading branch information...
1 parent 3d01140 commit 0faf250ae99a15a9d46720d8db8016e81351919d @jjallaire jjallaire committed Jun 18, 2012
Showing with 7 additions and 0 deletions.
  1. +7 −0 dependencies/linux/install-dependencies-debian
@@ -28,6 +28,10 @@ sudo apt-get -y install libbz2-dev
sudo apt-get -y install zlib1g-dev
sudo apt-get -y install libpam-dev
+# app armor dependencies no longer included in ubuntu >= 11.10
+sudo apt-get -y install libapparmor1
+sudo apt-get -y install apparmor-utils
+
# boost
sudo apt-get -y install libboost-all-dev
@@ -54,6 +58,9 @@ then
sudo apt-get -y install libgstreamer0.10-0
sudo apt-get -y install libgstreamer-plugins-base0.10-0
+ # Ubuntu 12.04 doesn't include libjpeg62 (and it's required by Qt 4.8)
+ sudo apt-get -y install libjpeg62
+
# install Qt 4.8 SDK (into a private /opt/RStudio-QtSDK directory so as to
# not conflict with any other installed versions of Qt on the system)
./install-qt-sdk

0 comments on commit 0faf250

Please sign in to comment.