New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

How can i use Sphinx v1.3 #1214

Closed
shangguokan opened this Issue Apr 1, 2015 · 3 comments

Comments

Projects
None yet
2 participants
@shangguokan

shangguokan commented Apr 1, 2015

conf.py
If your documentation needs a minimal Sphinx version, state it here.
needs_sphinx = '1.3'

build message
Sphinx version error:
This project needs at least Sphinx v1.3 and therefore cannot be built with this version.

I need to use some new features of Sphinx v1.3, for exemple: option 'caption' of code-block
Some body know how can i build with v1.3 replace the v1.2.2 current?

@agjohnson

This comment has been minimized.

Contributor

agjohnson commented Apr 7, 2015

We haven't rolled out support for 1.3.1 yet, parts of our theme are broken because of changes in 1.3. We expect a release in the next few weeks.

@shangguokan shangguokan closed this Apr 7, 2015

agjohnson added a commit to agjohnson/readthedocs.org that referenced this issue May 4, 2015

@agjohnson

This comment has been minimized.

Contributor

agjohnson commented May 5, 2015

Just an update here -- Sphinx 1.3.1 support has been released, including support for captions.

@shangguokan

This comment has been minimized.

shangguokan commented May 6, 2015

Thanks cool!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment