New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Error in YAML configuration docs: default value for `python.setup_py_install` should be `true` #3334

Closed
jonrkarr opened this Issue Nov 30, 2017 · 5 comments

Comments

Projects
None yet
5 participants
@jonrkarr

jonrkarr commented Nov 30, 2017

Regarding the YAML configuration docs (http://docs.readthedocs.io/en/latest/yaml-config.html), the default for python.setup_py_install appears to be true rather than false which is stated in the documentation

@RichardLitt

This comment has been minimized.

Member

RichardLitt commented Nov 30, 2017

Sounds like a small PR is in order. :)

@jonrkarr

This comment has been minimized.

jonrkarr commented Dec 2, 2017

Thanks for building the conda feature! This is very helpful for documenting packages that require more complex environments.

One more suggestion: I think it would helpful to expand the conda to note to say that requirements.txt files are not used when the conda option is used. If the conda option is used, all requirements must be invoked by setup.py or stated in environment.yml.

@humitos

This comment has been minimized.

Member

humitos commented Dec 3, 2017

Thanks for your report.

Perhaps there should be a mention of projects that have never had a successful build.

I would suggest you to create a new issue for this since it's different from the one reported. Thanks!

JavaDevVictoria added a commit to JavaDevVictoria/readthedocs.org that referenced this issue Dec 4, 2017

Updated python.setup_py_install to be true
Updated python.setup_py_install to be true, as per issue 3334: rtfd#3334
@JavaDevVictoria

This comment has been minimized.

JavaDevVictoria commented Dec 4, 2017

Hi, I have submitted a pull request for this issue here: #3357

@agjohnson

This comment has been minimized.

Contributor

agjohnson commented Dec 14, 2017

I tested that the following were all true:

  • Default model value for installing project is False
  • Default config value for installing project is False
  • Bare project doesn't attempt to install project

So, the documentation still seems correct, this option does not seem to be enabled by default. Feel free to reopen if you have a specific case that shows otherwise, but as it stands, I don't think we need to update our docs.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment