Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

allow_reload/revalidate is not enabled by default #63

Merged
merged 1 commit into from

2 participants

@mislav

These comments were left over after d268152

@rtomayko
Owner

Not sure how I missed this. Thanks!

@rtomayko rtomayko merged commit 71a2e46 into from
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on May 17, 2012
  1. @mislav

    allow_reload/revalidate is not enabled by default

    mislav authored
    These comments were left over after
    d268152
This page is out of date. Refresh to see the latest.
Showing with 4 additions and 6 deletions.
  1. +4 −6 lib/rack/cache/options.rb
View
10 lib/rack/cache/options.rb
@@ -95,14 +95,12 @@ def option_name(key)
# Default: ['Authorization', 'Cookie']
option_accessor :private_headers
- # Specifies whether the client can force a cache reload by including a
- # Cache-Control "no-cache" directive in the request. This is enabled by
- # default for compliance with RFC 2616.
+ # Specifies whether a client can force cache reload by including a
+ # Cache-Control "no-cache" directive in the request. Disabled by default.
option_accessor :allow_reload
- # Specifies whether the client can force a cache revalidate by including
- # a Cache-Control "max-age=0" directive in the request. This is enabled by
- # default for compliance with RFC 2616.
+ # Specifies whether a client can force cache revalidate by including a
+ # Cache-Control "max-age=0" directive in the request. Disabled by default.
option_accessor :allow_revalidate
# Specifies whether the underlying entity store's native expiration should
Something went wrong with that request. Please try again.