This repository has been archived by the owner. It is now read-only.

Rocco breaks ActiveRecord 2.3.8 #45

Closed
jamesarosen opened this Issue May 18, 2011 · 1 comment

Comments

2 participants

If I put Rocco in any gem group that gets loaded with my application (such as dev or none), I get the following error (with newlines inserted for readability):

/Users/me/.rvm/gems/ree-1.8.7-2011.03/gems/
  activerecord-2.3.10/lib/active_record/associations/
  association_proxy.rb:146:
  in `exists?': wrong number of arguments (0 for 1) (ArgumentError)

I can solve the issue by moving Rocco to a different gem group:

# in Gemfile:
group :docs do
  gem 'rocco', '~> 0.6.0'
end
Owner

rtomayko commented May 18, 2011

This is likely due to lib/rocco.rb including FileTest here:

include FileTest

@rtomayko rtomayko closed this in 9e88a39 May 23, 2011

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.