Multithreaded test suite error #93

Closed
voxik opened this Issue Jun 24, 2011 · 4 comments

Projects

None yet

2 participants

@voxik
Contributor
voxik commented Jun 24, 2011

Hi guys,

from time to time, I observe this multithreading error in test suite:

  1) Error:
test_using_compiled_templates_from_multiple_threads(CompileSiteTest):
SyntaxError: compile error
(__TEMPLATE__):2: syntax error, unexpected '=', expecting kEND
               local-71868248 = locals[:local-71868248]
                               ^
    (__TEMPLATE__):8:in `compile_template_method'
    ./test/tilt_compilesite_test.rb:48:in `join'
    ./test/tilt_compilesite_test.rb:48:in `test_using_compiled_templates_from_multiple_threads'
    ./test/tilt_compilesite_test.rb:48:in `each'
    ./test/tilt_compilesite_test.rb:48:in `test_using_compiled_templates_from_multiple_threads'
    ./test/tilt_compilesite_test.rb:34:in `times'
    ./test/tilt_compilesite_test.rb:34:in `test_using_compiled_templates_from_multiple_threads'

I observed this error on Fedora 16 recently. The Fedora package build passes due to this issues just sometimes. This is the Fedora bug report: https://bugzilla.redhat.com/show_bug.cgi?id=715713

@judofyr
Collaborator
judofyr commented Jun 24, 2011

This is a test error (the code works just fine). I'll commit a fix later
today.

@voxik
Contributor
voxik commented Jun 24, 2011

Thank you. I appreciate it.

@judofyr judofyr closed this in a07077f Jun 24, 2011
@judofyr
Collaborator
judofyr commented Jun 24, 2011

Can you try latest master? Thanks for the report!

@voxik
Contributor
voxik commented Jun 24, 2011

I applied the patch and tried to build the package 5 times and always successful, so it seems that this patch fixes the issue.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment