Permalink
Browse files

Fixed a system/local conflict problem

If blimpy gem is already installed, this ends up picking blimpy from the installed gem, as opposed to the local workspace.
  • Loading branch information...
1 parent cd1ebc2 commit 2edd265e92fa04e615962b2db07b82e9bcda18a6 @kohsuke kohsuke committed Mar 29, 2013
Showing with 2 additions and 6 deletions.
  1. +2 −6 bin/blimpy
View
@@ -10,12 +10,8 @@ rescue NameError
# I don't think we have YAML::ENGINE until Ruby 1.9
end
-begin
- require 'blimpy/cli'
-rescue LoadError
- $:.unshift File.expand_path(File.dirname(__FILE__) + '/../lib/')
- require 'blimpy/cli'
-end
+$:.unshift File.expand_path(File.dirname(__FILE__) + '/../lib/')
+require 'blimpy/cli'
# allow monkey-patching of Blimpy by the project (mainly to add more commands)
blimprc = File.join(Dir.pwd,"Blimprc")

0 comments on commit 2edd265

Please sign in to comment.