@rtyley rtyley released this Jan 31, 2018 · 1 commit to master since this release

Assets 2

This release updates the BFG to use Scala 2.12 (from 2.11), which in turn raises the requirement for Java to Java 8.

This makes BFG v1.12.3 the last version to support Java 6, and BFG v1.12.16 the last version to support Java 7.

I've added a new helper library use-newer-java to guard against lower Java versions- it'll display a message like this:

Looks like your version of Java (1.7) is too old to run this program.

You'll need to get Java 8 or later.

That might sound like a pretty minimal message, but it is at least better than java.lang.UnsupportedClassVersionError : Unsupported major.minor version 52.0, which is the default exception thrown when the version of Java is too old!