Permalink
Browse files

Explicitly requiring ruby_transform/transformer to minimize load orde…

…r issues.
  • Loading branch information...
rubiety committed Apr 2, 2012
1 parent 040beb1 commit 3352837a2cf0c4ff6556f0fbe279a147e9caf81f
Showing with 4 additions and 0 deletions.
  1. +2 −0 Gemfile.lock
  2. +2 −0 lib/ruby_transform.rb
View
@@ -17,6 +17,7 @@ GEM
diff-lcs (1.1.3)
i18n (0.6.0)
multi_json (1.2.0)
+ rake (0.9.2.2)
rspec (2.6.0)
rspec-core (~> 2.6.0)
rspec-expectations (~> 2.6.0)
@@ -39,5 +40,6 @@ PLATFORMS
ruby
DEPENDENCIES
+ rake
rspec (~> 2.0)
ruby_transform!
View
@@ -3,6 +3,8 @@
require "ruby_parser"
require "ruby_scribe"
+require "ruby_transform/transformer"
+
Dir[File.join(File.dirname(__FILE__), "ruby_transform/**/**/*.rb")].each do |file|
require file
end

0 comments on commit 3352837

Please sign in to comment.