Skip to content
Permalink
Browse files
Try adding Dockerfiles for ubuntu 14.04, 15.10.
[ci skip]
  • Loading branch information
brixen committed Jan 3, 2016
1 parent 28fe898 commit 619e0e2573ce9f3c0c6a80dbe3ebdc706baad7f0
Showing with 52 additions and 0 deletions.
  1. +26 −0 dockerfiles/ubuntu/14.04/Dockerfile
  2. +26 −0 dockerfiles/ubuntu/15.10/Dockerfile
@@ -0,0 +1,26 @@
FROM ubuntu:14.04

RUN apt-get -y update && apt-get -y install build-essential bison ruby \
ruby-dev rake zlib1g-dev libyaml-dev libssl-dev libreadline-dev \
libncurses5-dev llvm-3.5 llvm-3.5-dev libeditline-dev libedit-dev

RUN gem install bundler

RUN apt-get -y install wget && \
wget http://releases.rubinius.com/rubinius-3.0.tar.bz2 \
-O /tmp/rubinius.tar.bz2

RUN locale-gen en_US.UTF-8
RUN dpkg-reconfigure locales
ENV LANG en_US.UTF-8
ENV LC_ALL en_US.UTF-8

RUN cd /tmp && tar jxf rubinius.tar.bz2 && rm *.tar.bz2 && cd rubinius-* && \
bundle install && \
./configure --prefix=/opt/rubinius \
--llvm-config=/usr/bin/llvm-config-3.5 && \
rake build && \
rake install && \
cd /tmp && rm -rf rubinius-*

ENV PATH /opt/rubinius/bin:/opt/rubinius/gems/bin:$PATH
@@ -0,0 +1,26 @@
FROM ubuntu:15.10

RUN apt-get -y update && apt-get -y install build-essential bison ruby \
ruby-dev rake zlib1g-dev libyaml-dev libssl-dev libreadline-dev \
libncurses5-dev llvm-3.5 llvm-3.5-dev libeditline-dev libedit-dev

RUN gem install bundler

RUN apt-get -y install wget && \
wget http://releases.rubinius.com/rubinius-3.0.tar.bz2 \
-O /tmp/rubinius.tar.bz2

RUN locale-gen en_US.UTF-8
RUN dpkg-reconfigure locales
ENV LANG en_US.UTF-8
ENV LC_ALL en_US.UTF-8

RUN cd /tmp && tar jxf rubinius.tar.bz2 && rm *.tar.bz2 && cd rubinius-* && \
bundle install && \
./configure --prefix=/opt/rubinius \
--llvm-config=/usr/bin/llvm-config-3.5 && \
rake build && \
rake install && \
cd /tmp && rm -rf rubinius-*

ENV PATH /opt/rubinius/bin:/opt/rubinius/gems/bin:$PATH

0 comments on commit 619e0e2

Please sign in to comment.