Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Fixed C-API include dir in ext_helper (thanks jfire).

  • Loading branch information...
commit 6559ccb5b15e0e2fc573fec35ea4101740356eec 1 parent a4b7984
@brixen brixen authored
Showing with 8 additions and 4 deletions.
  1. +1 −1  Rakefile
  2. +1 −1  configure
  3. +6 −2 rakelib/ext_helper.rb
View
2  Rakefile
@@ -33,7 +33,7 @@ end
require config_rb
BUILD_CONFIG = Rubinius::BUILD_CONFIG
-unless BUILD_CONFIG[:config_version] == 147
+unless BUILD_CONFIG[:config_version] == 148
STDERR.puts "Your configuration is outdated, please run ./configure first"
exit 1
end
View
2  configure
@@ -114,7 +114,7 @@ class Configure
@libversion = "2.0"
@version = "#{@libversion}.0dev"
@release_date = "yyyy-mm-dd"
- @config_version = 147
+ @config_version = 148
# TODO: add conditionals for platforms
if RbConfig::CONFIG["build_os"] =~ /darwin/
View
8 rakelib/ext_helper.rb
@@ -140,8 +140,12 @@ def add_rbx_capi
add_cflag "-O2"
add_cxxflag "-O2"
end
- add_include_dir include18_dir
- add_include_dir include19_dir
+
+ if RUBY_VERSION =~ /^1\.8/
+ add_include_dir include18_dir
+ else
+ add_include_dir include19_dir
+ end
end
# Setup some initial computed values
Please sign in to comment.
Something went wrong with that request. Please try again.