Permalink
Browse files

fixed Rake deprecation warning

  • Loading branch information...
1 parent bdcdee2 commit 95bb2fee8c56b96db99c0040e393eabe11636026 @nazgob nazgob committed May 18, 2012
Showing with 2 additions and 0 deletions.
  1. +2 −0 Rakefile
View
@@ -1,6 +1,8 @@
# NOTE! When updating this file, also update INSTALL, if necessary.
# NOTE! Please keep your tasks grouped together.
+include Rake::DSL
+
if ENV["RUBYLIB"]
STDERR.puts "ERROR: Please unset RUBYLIB to build Rubinius"
exit 1

4 comments on commit 95bb2fe

Owner

dbussink replied May 19, 2012

This breaks with Rake 0.8.7. @brixen do you feel like we still want to support Rake 0.8.7 for building Rubinius?

Member

nazgob replied May 19, 2012

Rake 0.8.7 was released in May 2009 so it's not THAT old. We can go with conditional include using Rake::VERSION for Rake 0.9+. Sounds ok?

Owner

evanphx replied May 19, 2012

Revert this commit.

Member

nazgob replied May 19, 2012

Done.

Please sign in to comment.