Permalink
Browse files

Build Syck even if Psych is available because Syck is still 1.9 default.

  • Loading branch information...
brixen committed Nov 11, 2011
1 parent fb64f53 commit 978ee887d303cc96046858538690d65252ad2e04
Showing with 5 additions and 5 deletions.
  1. +1 −1 Rakefile
  2. +1 −1 configure
  3. +3 −3 rakelib/extensions.rake
View
@@ -33,7 +33,7 @@ end
require config_rb
BUILD_CONFIG = Rubinius::BUILD_CONFIG
-unless BUILD_CONFIG[:config_version] == 142
+unless BUILD_CONFIG[:config_version] == 143
STDERR.puts "Your configuration is outdated, please run ./configure first"
exit 1
end
View
@@ -115,7 +115,7 @@ class Configure
@libversion = "2.0"
@version = "#{@libversion}.0dev"
@release_date = "yyyy-mm-dd"
- @config_version = 142
+ @config_version = 143
# TODO: add conditionals for platforms
if RbConfig::CONFIG["build_os"] =~ /darwin/
View
@@ -134,11 +134,11 @@ if BUILD_CONFIG[:readline] == :c_readline
end
if BUILD_CONFIG[:libyaml]
- compile_ext "psych", :deps => ["Makefile"], :dir => "lib/19/psych/ext"
-else
- compile_ext "syck", :deps => ["Makefile"], :dir => "lib/19/syck/ext", :env => "-X19"
+ compile_ext "psych", :deps => ["Makefile"], :dir => "lib/19/psych/ext", :env => "-X19"
end
+compile_ext "syck", :deps => ["Makefile"], :dir => "lib/19/syck/ext", :env => "-X19"
+
# rbx must be able to run to build these because they use
# extconf.rb, so they must be after melbourne for Rubinius.
compile_ext "openssl", :deps => ["Makefile", "extconf.h"]

0 comments on commit 978ee88

Please sign in to comment.