Permalink
Browse files

Ensure Rakefile checks configure version before anything. Closes #385.

  • Loading branch information...
1 parent ddc4d8a commit e846db9f3cf744387f152663c73005facb871c31 Brian Ford committed Jun 23, 2010
Showing with 6 additions and 6 deletions.
  1. +5 −5 Rakefile
  2. +1 −1 configure
View
@@ -22,14 +22,14 @@ end
require config_rb
BUILD_CONFIG = Rubinius::BUILD_CONFIG
-# Yes, this is duplicated from the configure script for now.
-unless BUILD_CONFIG[:which_ruby] == :ruby or BUILD_CONFIG[:which_ruby] == :rbx
- STDERR.puts "Sorry, building Rubinius requires MRI or Rubinius"
+unless BUILD_CONFIG[:config_version] == 11
+ STDERR.puts "Your configuration is outdated, please run ./configure first"
exit 1
end
-unless BUILD_CONFIG[:config_version] == 10
- STDERR.puts "Your configuration is outdated, please run ./configure first"
+# Yes, this is duplicated from the configure script for now.
+unless BUILD_CONFIG[:which_ruby] == :ruby or BUILD_CONFIG[:which_ruby] == :rbx
+ STDERR.puts "Sorry, building Rubinius requires MRI or Rubinius"
exit 1
end
View
@@ -59,7 +59,7 @@ class Configure
@libversion = "1.0"
@version = "#{@libversion}.1"
@release_date = "2010-06-03"
- @config_version = 10
+ @config_version = 11
if !ENV['RELEASE'] and File.directory?(root + "/.git")
@buildrev = `git rev-list --all | head -n1`.chomp

0 comments on commit e846db9

Please sign in to comment.