Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Could not locate Gemfile #1901

Closed
mulderp opened this Issue · 3 comments

2 participants

@mulderp

I am trying to install Rubinius in my Rbenv environment, which is:

rbenv 0.3.0
ruby 1.8.7 (2012-02-08 patchlevel 358) [i686-darwin11.3.0]
ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-darwin11.3.0]

I did

sudo brew install libyaml
and got: libyaml-0.1.4

Configuration with path to my rbenv:
./configure --prefix=~/.rbenv/versions/rbx-2.0.0-dev --enable-version=1.8,1.9 --default-version=1.9

I then get a:

Checking for header 'sys/pstat.h': not found

and the command

rake says:

Could not locate Gemfile

Any pointers?

@dbussink
Owner

There is nothing that Rubinius needs Bundler for. Perhaps you have setup some environment variables or wrappers that automatically try to load Bundler or do something like bundle exec?

The pstat.h is not an issue, since configure explicitly checks whether that's available and whether it should use it or not.

@mulderp

Thanks for the pointer.
After some research, I think the problem is around my rake setup from rbenv:

/Users/pmu/.rbenv/shims/rake

I just added a Gemfile that was asked for

cat > Gemfile
source "https://rubygems.org"
gem "rake"

bundle

and rake install runs fine:
Finished in 266.391693 seconds
3891 files, 21908 examples, 141958 expectations, 1 failure, 0 errors

@mulderp mulderp closed this
@mulderp

PS the install with homebrew directly worked

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.