An exception occurred running rbx-head/bin/bundle #245

Closed
rolfb opened this Issue Apr 2, 2010 · 4 comments

Comments

Projects
None yet
5 participants
@rolfb

rolfb commented Apr 2, 2010

bundle install failed
Gemfile:

### gemfile ###
source 'http://rubygems.org'

gem 'rails', :git => 'git://github.com/rails/rails.git'

gem 'sqlite3-ruby', :require => 'sqlite3'

# Use unicorn as the web server
gem 'unicorn'

gem 'database_cleaner', :git => 'git://github.com/bmabey/database_cleaner.git'
gem 'rspec-rails', :git => 'git://github.com/rspec/rspec-rails.git'
gem 'rspec', :git => 'git://github.com/rspec/rspec.git'
gem 'test-unit'
gem 'cucumber-rails', :git => 'git://github.com/aslakhellesoy/cucumber-rails.git'
gem 'capybara', :git => 'git://github.com/jnicklas/capybara.git'
gem 'launchy'
gem 'devise', :git => 'git://github.com/plataformatec/devise.git'
gem 'spork'

# Deploy with Capistrano
# gem 'capistrano'

# Bundle the extra gems:
# gem 'bj'
# gem 'nokogiri', '1.4.1'
# gem 'sqlite3-ruby', :require => 'sqlite3'
# gem 'aws-s3', :require => 'aws/s3'

# Bundle gems for certain environments:
#gem 'rspec', :group => :test
#group :test do
#end

### end of gemfile ###


An exception occurred running /Users/rolf/.rvm/gems/rbx-head/bin/bundle
    unable to open lib/set.rb to set DATA, source .rb file does not exist. (RuntimeError)

Backtrace:
                     Rubinius.set_data at kernel/delta/rubinius.rb:230
                       main.__script__ at lib/set.rb:629
    Rubinius::CompiledMethod#as_script at kernel/common/compiled_method.rb:242
           Requirer::Utils.single_load at kernel/delta/requirer.rb:267
       Requirer::Utils.unified_load {} at kernel/delta/requirer.rb:140
                            Array#each at kernel/bootstrap/array.rb:156
          Requirer::Utils.unified_load at kernel/delta/requirer.rb:105
  Kernel(Object)#gem_original_require (require) at kernel/common/kernel.rb:747
                Kernel(Object)#require at lib/rubygems/custom_require.rb:31
                       main.__script__ at /Users/rolf/.rvm/gems/rbx-head/gems/bundler-0.9.15/lib/bundler/resolver.rb:1
    Rubinius::CompiledMethod#as_script at kernel/common/compiled_method.rb:242
           Requirer::Utils.single_load at kernel/delta/requirer.rb:267
       Requirer::Utils.unified_load {} at kernel/delta/requirer.rb:140
                            Array#each at kernel/bootstrap/array.rb:156
          Requirer::Utils.unified_load at kernel/delta/requirer.rb:105
                         Autoload#call at kernel/common/autoload.rb:27
  Bundler::Environment(Bundler::Installer)#resolve at /Users/rolf/.rvm/gems/rbx-head/gems/bundler-0.9.15/lib/bundler/environment.rb:55
   Bundler::Installer#resolve_remotely at /Users/rolf/.rvm/gems/rbx-head/gems/bundler-0.9.15/lib/bundler/installer.rb:67
  Bundler::Environment(Bundler::Installer)#specs at /Users/rolf/.rvm/gems/rbx-head/gems/bundler-0.9.15/lib/bundler/environment.rb:28
                Bundler::Installer#run at /Users/rolf/.rvm/gems/rbx-head/gems/bundler-0.9.15/lib/bundler/installer.rb:21
            Bundler::Installer.install at /Users/rolf/.rvm/gems/rbx-head/gems/bundler-0.9.15/lib/bundler/installer.rb:6
                  Bundler::CLI#install at /Users/rolf/.rvm/gems/rbx-head/gems/bundler-0.9.15/lib/bundler/cli.rb:88
                        Thor::Task#run at /Users/rolf/.rvm/gems/rbx-head/gems/bundler-0.9.15/lib/bundler/vendor/thor/task.rb:33
  Thor::Invocation(Bundler::CLI)#invoke {} at /Users/rolf/.rvm/gems/rbx-head/gems/bundler-0.9.15/lib/bundler/vendor/thor/invocation.rb:109
  Thor::Invocation(Bundler::CLI)#invoke at /Users/rolf/.rvm/gems/rbx-head/gems/bundler-0.9.15/lib/bundler/vendor/thor/invocation.rb:116
                         Thor.start {} at /Users/rolf/.rvm/gems/rbx-head/gems/bundler-0.9.15/lib/bundler/vendor/thor.rb:137
  Thor::Base::ClassMethods(Class)#start at /Users/rolf/.rvm/gems/rbx-head/gems/bundler-0.9.15/lib/bundler/vendor/thor/base.rb:540
                            Thor.start at /Users/rolf/.rvm/gems/rbx-head/gems/bundler-0.9.15/lib/bundler/vendor/thor.rb:124
                       main.__script__ at /Users/rolf/.rvm/gems/rbx-head/gems/bundler-0.9.15/bin/bundle:13
    Rubinius::CompiledMethod#as_script at kernel/common/compiled_method.rb:242
           Requirer::Utils.single_load at kernel/delta/requirer.rb:267
          Requirer::Utils.unified_load at kernel/delta/requirer.rb:98
                   Kernel(Object)#load at kernel/common/kernel.rb:697
                       main.__script__ at /Users/rolf/.rvm/gems/rbx-head/bin/bundle:19
    Rubinius::CompiledMethod#as_script at kernel/common/compiled_method.rb:242
           Requirer::Utils.single_load at kernel/delta/requirer.rb:267
   Requirer::Utils.load_from_extension at kernel/delta/requirer.rb:352
               Rubinius::Loader#script at kernel/loader.rb:417
                 Rubinius::Loader#main at kernel/loader.rb:528
                     Object#__script__ at kernel/loader.rb:533
@reactormonk

This comment has been minimized.

Show comment Hide comment
@reactormonk

reactormonk Apr 4, 2010

It's set.rb - got a really strange construct of containing its own tests. However, changing the file and changing it back solved the problem... my suggestion is deleting DATA.eval

It's set.rb - got a really strange construct of containing its own tests. However, changing the file and changing it back solved the problem... my suggestion is deleting DATA.eval

@vlazar

This comment has been minimized.

Show comment Hide comment
@vlazar

vlazar Apr 5, 2010

I've got the same error for "ruby -S script/server" using simple blog scaffold application (OSX 10.6.2, Rubinius 1.0rc4, RVM 0.1.25, Rails 2.3.5).

vlazar commented Apr 5, 2010

I've got the same error for "ruby -S script/server" using simple blog scaffold application (OSX 10.6.2, Rubinius 1.0rc4, RVM 0.1.25, Rails 2.3.5).

@freeformz

This comment has been minimized.

Show comment Hide comment
@freeformz

freeformz Apr 15, 2010

OSX 10.6.3
rubinius 1.0.0-rc4 (1.8.7 e21c1d6 2010-03-31 JI) [x86_64-apple-darwin10.3.0]

rbx gem install rack
rbx
require 'rack/utils'
RuntimeError: unable to open lib/set.rb to set DATA, source .rb file does not exist.
from Rubinius.set_data at kernel/delta/rubinius.rb:230
from main.__script__ at lib/set.rb:629
from Rubinius::CompiledMethod#as_script at kernel/common/compiled_method.rb:242
from Requirer::Utils.single_load at kernel/delta/requirer.rb:289
from Requirer::Utils.unified_load {} at kernel/delta/requirer.rb:140
from Array#each at kernel/bootstrap/array.rb:156
from Requirer::Utils.unified_load at kernel/delta/requirer.rb:105
from Kernel(Object)#gem_original_require (require) at kernel/common/kernel.rb:739
from Kernel(Object)#require at lib/rubygems/custom_require.rb:31
from main.__script__ at /usr/local/rubinius/gems/1.8/gems/rack-1.1.0/lib/rack/utils.rb:3
from Rubinius::CompiledMethod#as_script at kernel/common/compiled_method.rb:242
from Requirer::Utils.single_load at kernel/delta/requirer.rb:289
from Requirer::Utils.unified_load {} at kernel/delta/requirer.rb:140
from Array#each at kernel/bootstrap/array.rb:156
from Requirer::Utils.unified_load at kernel/delta/requirer.rb:105
from Kernel(Object)#gem_original_require (require) at kernel/common/kernel.rb:739
from Kernel(Object)#require at lib/rubygems/custom_require.rb:31
from Object#irb_binding {} at (irb):6

OSX 10.6.3
rubinius 1.0.0-rc4 (1.8.7 e21c1d6 2010-03-31 JI) [x86_64-apple-darwin10.3.0]

rbx gem install rack
rbx
require 'rack/utils'
RuntimeError: unable to open lib/set.rb to set DATA, source .rb file does not exist.
from Rubinius.set_data at kernel/delta/rubinius.rb:230
from main.__script__ at lib/set.rb:629
from Rubinius::CompiledMethod#as_script at kernel/common/compiled_method.rb:242
from Requirer::Utils.single_load at kernel/delta/requirer.rb:289
from Requirer::Utils.unified_load {} at kernel/delta/requirer.rb:140
from Array#each at kernel/bootstrap/array.rb:156
from Requirer::Utils.unified_load at kernel/delta/requirer.rb:105
from Kernel(Object)#gem_original_require (require) at kernel/common/kernel.rb:739
from Kernel(Object)#require at lib/rubygems/custom_require.rb:31
from main.__script__ at /usr/local/rubinius/gems/1.8/gems/rack-1.1.0/lib/rack/utils.rb:3
from Rubinius::CompiledMethod#as_script at kernel/common/compiled_method.rb:242
from Requirer::Utils.single_load at kernel/delta/requirer.rb:289
from Requirer::Utils.unified_load {} at kernel/delta/requirer.rb:140
from Array#each at kernel/bootstrap/array.rb:156
from Requirer::Utils.unified_load at kernel/delta/requirer.rb:105
from Kernel(Object)#gem_original_require (require) at kernel/common/kernel.rb:739
from Kernel(Object)#require at lib/rubygems/custom_require.rb:31
from Object#irb_binding {} at (irb):6
@brixen

This comment has been minimized.

Show comment Hide comment
@brixen

brixen Apr 19, 2010

Owner

Interim fix for DATA. Closed by b3cab4b.

Owner

brixen commented Apr 19, 2010

Interim fix for DATA. Closed by b3cab4b.

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment