Skip to content

Intermittent segfault when running tests on rbx-2.2.1 #2841

Open
benweint opened this Issue Dec 18, 2013 · 3 comments

2 participants

@benweint

We're seeing occasional segfaults when running the test suites for the newrelic_rpm gem against rbx-2.2.1. They don't happen every time (or even most of the time).

I unfortunately don't have a reliable reproduction case yet, but here's an example stack trace:
https://gist.github.com/anonymous/50931a5aeee668acd219

I'll update here with more info if I figure out how to reproduce this.

$ rbx -v
rubinius 2.2.1 (2.1.0 3ed43137 2013-11-17 JI) [x86_64-linux-gnu]
$ uname -a
Linux <hostname redacted> 2.6.32-279.el6.x86_64 #1 SMP Fri Jun 22 12:19:21 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
@YorickPeterse
Rubinius member

Do these crashes still occur using Rubinius 2.5.2?

@YorickPeterse
Rubinius member

@benweint Have you been experiencing issues like these using more recent releases of Rubinius (e.g. 2.5.2)? With 2.5.3 released, is it possible to give that version a try to see how that works?

@benweint

Hey @YorickPeterse! Sorry for the lack of updates here.

We actually stopped running our full test suite (we still run our unit tests there, but not all of our functional tests) on rbx because of this and other similar issues (#3291, #3213), so I can't say for sure whether this has been fixed in recent versions or not.

I'll try to replicate this manually by running our tests in a loop if I get a chance soon and report back.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.