Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

rbx gem install nokogiri failed #287

Closed
Flamefork opened this Issue May 14, 2010 · 12 comments

Comments

Projects
None yet
5 participants

/opt/rubinius/bin/rbx extconf.rb
checking for iconv.h in /opt/local/include/,/opt/local/include/libxml2,/opt/local/include,/opt/local/include,/opt/local/include/libxml2,/usr/local/include,/usr/local/include/libxml2,/opt/rubinius/include,/opt/rubinius/include/libxml2,/usr/include,/usr/include/libxml2... yes
checking for libxml/parser.h in /opt/local/include/,/opt/local/include/libxml2,/opt/local/include,/opt/local/include,/opt/local/include/libxml2,/usr/local/include,/usr/local/include/libxml2,/opt/rubinius/include,/opt/rubinius/include/libxml2,/usr/include,/usr/include/libxml2... yes
checking for libxslt/xslt.h in /opt/local/include/,/opt/local/include/libxml2,/opt/local/include,/opt/local/include,/opt/local/include/libxml2,/usr/local/include,/usr/local/include/libxml2,/opt/rubinius/include,/opt/rubinius/include/libxml2,/usr/include,/usr/include/libxml2... yes
checking for libexslt/exslt.h in /opt/local/include/,/opt/local/include/libxml2,/opt/local/include,/opt/local/include,/opt/local/include/libxml2,/usr/local/include,/usr/local/include/libxml2,/opt/rubinius/include,/opt/rubinius/include/libxml2,/usr/include,/usr/include/libxml2... yes
checking for xmlParseDoc() in -lxml2... yes
checking for xsltParseStylesheetDoc() in -lxslt... yes
checking for exsltFuncRegister() in -lexslt...

It sure installs in regular ruby and in rubyee on this machine.
OS X 10.6

Member

luislavena commented May 14, 2010

Hello,

Can you post the other errors it generates? so far all the checks you posted do not provide information about the error.

Thank you.

Owner

evanphx commented May 14, 2010

I've seen this pop up a few times. I'll investigate it.

Contributor

yaroslav commented May 15, 2010

Same here. 10.6.3, rubinius 1.0.0

Seeing the same issue. Here is some additional debug info (including the gem folder) http://gist.github.com/402485

Please describe what do I need to post in addition... since it's the only output between common lines.
OSX 10.6.3, libxml2 2.7.6 via macports

Probably would help to upload your mkmf.log file (cd into the gem folder, then ext/nokogiri/mkmf.log). Here is mine: http://cl.ly/d8481ff8ba9d04fdffbe

Owner

evanphx commented May 16, 2010

It appears that there rbx running extconf.rb crashes for some reason. This is my top priority item for Monday and 1.0.1.

Contributor

yaroslav commented May 16, 2010

I've succeeded to install nokogiri finally, after 3 or 4 attempts just mashing "gem install nokogiri" with no changes.

Owner

evanphx commented May 16, 2010

Yeah, thats consistent with there being a spurious crash.

Successfully installed after upgrading libxml2 from 2.7.6 to 2.7.7

Owner

evanphx commented May 17, 2010

Update StackVariable::last_match_ in the GC. Closed by fa4d2e6.

Tags: @critical

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment