Invalid Encoding when building on Ruby 1.9.1 #290

Closed
postmodern opened this Issue May 15, 2010 · 3 comments

Comments

Projects
None yet
3 participants
Contributor

postmodern commented May 15, 2010

Just noticed a basic encoding issue when running rake under Ruby 1.9.1:

Updating dependencies...
rake aborted!
invalid byte sequence in US-ASCII
/home/hal/rubinius/rakelib/dependency_grapher.rb:379:in `match'
/home/hal/rubinius/rakelib/dependency_grapher.rb:379:in `match'
/home/hal/rubinius/rakelib/dependency_grapher.rb:379:in `block in parse'
/home/hal/rubinius/rakelib/dependency_grapher.rb:377:in `each'
/home/hal/rubinius/rakelib/dependency_grapher.rb:377:in `parse'
/home/hal/rubinius/rakelib/dependency_grapher.rb:371:in `parse_file'
/home/hal/rubinius/rakelib/dependency_grapher.rb:417:in `block in process'
/usr/lib/ruby19/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:1277:in `each'
/usr/lib/ruby19/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:1277:in `each'
/home/hal/rubinius/rakelib/dependency_grapher.rb:413:in `process'
/home/hal/rubinius/rakelib/vm.rake:688:in `block in <top (required)>'
/usr/lib/ruby19/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:634:in `call'
/usr/lib/ruby19/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:634:in `block in execute'
/usr/lib/ruby19/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:631:in `each'
/usr/lib/ruby19/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:631:in `execute'
/usr/lib/ruby19/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:597:in `block in invoke_with_call_chain'
/usr/lib/ruby19/1.9.1/monitor.rb:190:in `mon_synchronize'
/usr/lib/ruby19/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:590:in `invoke_with_call_chain'
/usr/lib/ruby19/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:583:in `invoke'
/usr/lib/ruby19/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:2447:in `load_imports'
/usr/lib/ruby19/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:2390:in `raw_load_rakefile'
/usr/lib/ruby19/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:2017:in `block in load_rakefile'
/usr/lib/ruby19/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_exception_handling'
/usr/lib/ruby19/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:2016:in `load_rakefile'
/usr/lib/ruby19/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:2000:in `block in run'
/usr/lib/ruby19/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_exception_handling'
/usr/lib/ruby19/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:1998:in `run'
/usr/lib/ruby19/gems/1.9.1/gems/rake-0.8.7/bin/rake:31:in `<top (required)>'
/usr/bin/rake:19:in `load'
/usr/bin/rake:19:in `<main>'
Owner

evanphx commented May 15, 2010

We don't support using 1.9 to build rubinius at present.

Contributor

postmodern commented May 15, 2010

When will Rubinius support building on 1.9? It is the current production release after all, and 1.9.2 is coming up.

Owner

brixen commented May 15, 2010

soon.

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment